Downloading problem

Discussion in 'Windows 7 Help and Support' started by desk, Nov 22, 2009.

  1. desk

    desk New Member

    Joined:
    Nov 21, 2009
    Messages:
    12
    Likes Received:
    0
    I have searched the forum but I have not found an answer to my particular problem, so forgive me if I have repeated a relevent thread.
    Whenever I attempt to download eg a driver I get the download window and it begins to download for a while then it stops.........it does not freeze because the animated graphic is still working, eventually it announces a time-out.
    I can go through the exercise again and it will stall at a different point. There is the odd time when it will download completely. I have never witnessed this with XP or Vista except for bandwidth. Also I think I have problems with video streaming now, BBC iplayer is not as good as it used to be........I was blaming the BBC, now I'm wonderng if there is a tie between the two problems. My average bandwidth is 8 Mbps

    Can anyone please help me on this?
     
  2. desk

    desk New Member

    Joined:
    Nov 21, 2009
    Messages:
    12
    Likes Received:
    0
    I'm not using anything other than the normal download method.
     
  3. desk

    desk New Member

    Joined:
    Nov 21, 2009
    Messages:
    12
    Likes Received:
    0
    Sorry, I've used both IE and Firefox......no different.
     
  4. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321

    Does it happen like this with ANYTHING you try to download ?
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Is your browser fast when loading different pages?

    Go to Start > Run, and type cmd. Now type ping google.com

    You should get replies in the 45ms range.

    What are you getting?
     
  6. desk

    desk New Member

    Joined:
    Nov 21, 2009
    Messages:
    12
    Likes Received:
    0
    It did happen with everything I downloaded...............but I "think" I've cured it. Time will tell.
    About the same time I installed W7 my router failed and I was given a replacement. Through my new router today I realised there was a firmware update.......it now seems to be working correctly, I'll keep you informed.
    Thanks for your help.
     
  7. desk

    desk New Member

    Joined:
    Nov 21, 2009
    Messages:
    12
    Likes Received:
    0
    No, it hasn't helped........downloads are still a problem.
    In fact it is the same on my laptop which has both XP and W7.
    The browser works fine otherwise.
    Does it point to the router, do you think?
     
  8. desk

    desk New Member

    Joined:
    Nov 21, 2009
    Messages:
    12
    Likes Received:
    0
    FOUND THE PROBLEM!!!
    I've disabled the firewall in my Belkin router.
    Easy when you know how.
    SOLVED!!!

    Thank you for your help
     
  9. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    NICE,.'

    Good call!!
     

Share This Page

Loading...