Downloads often corrupt after installing Windows 7

Discussion in 'Windows 7 Help and Support' started by RTomsett, Aug 20, 2010.

  1. RTomsett

    RTomsett New Member

    Joined:
    Aug 20, 2010
    Messages:
    8
    Likes Received:
    0
    Hi all,

    I installed Windows 7 Home Premium today (fresh install on formatted hard disk) and am downloading some programs I used previously with Vista. I'm getting a hell of a lot of corrupted downloads though - Adobe Reader gives a checksum error when I try to extract it, Toontrack EZDrummer (which uses an Aladdin self-extracting archive) gives a CRC mismatch error when I try to extract it, the nVidia graphics drivers had some 7zip error when I tried to extract them (fortunately got a working download from somewhere else for those) also got a 7zip error trying to install Avast! antivirus. Some other downloads work fine. This happens when downloading with IE, Chrome and Firefox (including using DownThemAll download manager), and was never a problem before I installed Windows 7. The errors are reproducible - so downloading the same program from the same place with different web browsers will always give the same problem when opening the program.

    Am I just being unlucky or is there some issue with Windows 7?

    Thanks!

    ETA: My PC is a desktop, Gigabyte EX58-UD5 motherboard, Intel Core i7 processor, 6GB RAM, Geforce GTX 275, 1TB Samsung SATA hard disk, if that's helpful at all...
    Richard
     
    #1 RTomsett, Aug 20, 2010
    Last edited: Aug 20, 2010
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Hello and Welcome.

    Downloads can be corrupted if the download process was not completed, also if a security software is blocking them.[​IMG]
     
  3. RTomsett

    RTomsett New Member

    Joined:
    Aug 20, 2010
    Messages:
    8
    Likes Received:
    0
    Hi, thanks for the reply! The download process definitely completes (tried multiple times with different browsers) and I haven't got any security software that could be blocking the downloads (AVG temporarily disabled, nothing else installed)...
     
  4. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    #4 cybercore, Aug 20, 2010
    Last edited: Aug 20, 2010
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Try checking here
    GA-EX58-UD5 (rev. 1.0) - GIGABYTE - Support&Download - Motherboard - Driver
    Select your Version of 7 x86 or x64, make sure all your drivers are updated, especially those for your LAN card. If you are using both Gig Cards and the teaming feature, perhaps rethink that. Try a single card without teaming, and maybe even try adjusting the speed and duplex of the gig card down to 100 half duplex, just to see if that helps correct anything.
     
  6. RTomsett

    RTomsett New Member

    Joined:
    Aug 20, 2010
    Messages:
    8
    Likes Received:
    0
    Thanks very much - think I do have up-to-date drivers installed but they were from a different place from your link so will try the ones you've linked to. Tried downloading with various download managers, and using Ubuntu on the same machine, but the downloads are still broken, so think it's almost certainly a Windows 7 problem...
     
  7. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Let me have a look at what you've got going on there. Type msinfo32 in the start menu then hit enter. File | save on the opened screen. Then zip the saved file and attach to a post.

    I don't know what the issue is yet, but I can assure you it is not Windows 7.
     
  8. RTomsett

    RTomsett New Member

    Joined:
    Aug 20, 2010
    Messages:
    8
    Likes Received:
    0
    Hi TorrentG,

    Here's the NFO file from msinfo32. Thinking about it you're right it'd be very odd if this was a Windows 7 problem, I just jumped to that conclusion as that was the only thing that had changed since I last tried to download anything. I'm pretty sure that the problems are occurring more frequently with larger downloaded files - could it be something to do with my internet connection? Would be a bit odd as neither of my flatmates are having problems with it and they download large files more often than me...
     

    Attached Files:

  9. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Remove AVG in safe mode using the tool found here:

    AV Uninstallers - Windows 7 Forums

    Boot to normal mode and install MSE.

    -----------

    Update your Realtek HD Audio driver that's currently from July 14, 2009. This is from August 3, 2010:

    Realtek
     
    cybercore and (deleted member) like this.

Share This Page

Loading...