Drag & Drop works for Hidden Administrator but not for Administrator user

Discussion in 'Windows 7 Help and Support' started by Rincewindwiz, Feb 14, 2011.

  1. Rincewindwiz

    Rincewindwiz Senior Member

    Joined:
    Feb 14, 2011
    Messages:
    21
    Likes Received:
    0
    I use an old XP app (JetToolbar - available at JetToolBar - Free software downloads and software reviews - CNET Download.com) and do not want to change but I cant make it work on Windows 7.
    The application installs and starts up just fine but it is not possible to drag icons/programs/files to the toolbar - I just get the 'no entry' sign (Circle with line through)

    However, the application runs fine when logged on to the hidden Administrator account. If I set up the application in the hidden Admin account and then log on as a normal admin user and run it from that account, the icons I set up are just not visible.

    So what do I have to change in my normal user account (member of administrators) to make this drag and drop work?

    I have tried 'Run as administrator' but that made no difference. Ive read about dropping to 'Run as User' apps from 'Run as Admin' apps but that's not the problem (at least problem occurs when app is run as user or run as admin)

    I have tried 'Turning off UAC' but that made no difference.

    So what else can I try?

    Thanks for any help.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You might check this, open properties on the taskbar. Start Menu tab and customize. Second page down has a enable context menus and dragging and dropping. Is yours checked?
     
  3. Rincewindwiz

    Rincewindwiz Senior Member

    Joined:
    Feb 14, 2011
    Messages:
    21
    Likes Received:
    0
    Fascinating series of options I never really examined before. Sadly, however, "Enable context menus etc" is ticked.
    Thanks for the thought
     
  4. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Have you tried running it in compatibility mode?
     
  5. Rincewindwiz

    Rincewindwiz Senior Member

    Joined:
    Feb 14, 2011
    Messages:
    21
    Likes Received:
    0
    Yes. makes no difference. Windows selected XP SP2 (in its infinite wisdom) but the problem remains.

    The idea of starting up XP emulation is very definitely sledge hammer to crack a nut and I don't propose to try.

    The fact that it woks under the hidden Admin account suggests (to me at least) that is is something to do with permissions but they have got very complicated and, apart from trying the simple stuff mentioned, I have no idea where to start :-(

    Thanks for the thoughts
     
  6. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
  7. Rincewindwiz

    Rincewindwiz Senior Member

    Joined:
    Feb 14, 2011
    Messages:
    21
    Likes Received:
    0
    This (TakeOwnership) is what I used to take ownership (as described in the original post)

    Just to be sure, I have uninstalled the app, deleted all traces and reinstalled the app for 'all users' as a normal user with Admin rights. I have then used "takeownership" to take ownership of the install directory (which is, I think, the only one the app uses. there are directory no references in its ini file and none that I can find in the registry).and files.

    I ran the program and it gave its usual message about searching for apps. That finished normally but there were no icons on the toolbar (exactly as described earlier).

    I then 'switched user' to the Hidden Administrator account and ran the program again. It again gave its usual initialisation message about searching for apps (so it looks like its running in a different directory or accessing different files). That finished normally but this time there were application icons on the toolbar.

    Poking around afterwards I found two new directories one under Administrator and one under Username. Each contained a .tbd file (which I presume contains the details of the icons to be displayed) The files were of pretty much the same size (237,056 and 203,776) and creation times showing they had just been created.

    Looking at their permissions, the file in the Administrator directory had an extra Group/User name called Administrator (not AdministratorS) so I added this group to the file in the Username directory with full control.

    Now as far as I can tell, the program, all files and directories have the same permissions but the program still will not display icons on the toolbar.

    Thanks Bill!!!:confused:
     
  8. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    "This (TakeOwnership) is what I used to take ownership (as described in the original post)"
    Sorry. I just could not see that you had used it in your posts?
     
  9. Rincewindwiz

    Rincewindwiz Senior Member

    Joined:
    Feb 14, 2011
    Messages:
    21
    Likes Received:
    0
    No - I don't think I did. Sorry for the incomplete info.
     
  10. Rincewindwiz

    Rincewindwiz Senior Member

    Joined:
    Feb 14, 2011
    Messages:
    21
    Likes Received:
    0
    [​IMG]

    I can offer another piece of information that may help.
    I have just noticed that if I run the toolbar as a hidden icon on the task bar, it sort of works in that if you click the icon you get the toolbar categories and if you then hover over one of those you get the full menu of icons (just like the normal XP start menu).
    So its just the task bar itself that does not work (i.e. will not display the icons/categories) - except when run from the hidden administrator.
    Now surely this must be a setting somewhere?
     
  11. Rincewindwiz

    Rincewindwiz Senior Member

    Joined:
    Feb 14, 2011
    Messages:
    21
    Likes Received:
    0
    Re: Drag & Drop works for Hidden Administrator but not for Administrator user SOLVED

    So much for Windows 7 Enterprise and Windows 7 Ultimate being the same
    The jet Toolbar application works fine under Windows 7 Ultimate but has the symptoms described under Enterprise. Presumably the default settings on security or something are different in the two versions
    Thanks Bill.
     

Share This Page

Loading...