[DRIVERS?] 100GB IDE Maxtor drive reports ~2TB and won't work.

Discussion in 'Windows 7 Hardware' started by Tiake, Dec 26, 2010.

  1. Tiake

    Tiake New Member

    Dec 26, 2010
    Likes Received:
    When I first built my pc, my Seagate SATA drive arrived DOE, so I used a older 100GB IDE Maxtor and used Windows 7 x86 without problems for about a month. The drive has since been used as a backup drive by my brother for the past 9 months. It has had no problems till now.

    I installed it under cable select, with a Ultra cable, as a primary and set boot order to my SATA. Started up Windows, drive recognized fine, formatted it to NTFS with 4096 allocation bytes. It had about 93GB of space, and I proceeded to start a 90GB transfer, while monitoring temps with Speccy. Left to use the restroom, and when I got back Speccy reported closing unexpectedly (not normal for it) and Windows 7 errored stating that the transfer location (IDE drive) didn't exist. A pop-up stated that Ma|tor$6L140T0$ $ $ $ $ $ $ $ $ $ $ ATA Device driver was installed???

    I don't know what this driver is, uninstalling it means the drive disappears from disk manager, but its reinstalled and reappears upon restart. The drive reports 2097184.00 GB and needs initialization each time I enter disk manager (Don't think initialization actually works, but no error reported). I cannot format the disk, its grayed out due to lack of initialization.

    I have tried SeaTools, as Seagate owns Maxtor, and the drive passes all the basic tests, but the program will not allow a format either. MaxBlast5 attempts to format the drive, recognizing it at 2TB?? and fails. I don't think the drive is bad...but I don't really know. Going to try setting jumpers to primary from cable select, but first I am going to attempt a Windows 7 install on the drive, seeing if it can format it there without that driver getting in the way.

    If anyone has any idea what this might be please let me know. My only other guess from drivers or a bad drive is maybe some kind of registry value being messed up? If so, I would love to know where this could be found.

    After rebooting to use my Windows 7 disk, I seen that my bios was also now registering the Harddrive as ~2TB. I am going to go with the drive is dead, or possibly my cable/port is no good. Tried jumpers for setting it as Master as well, not that I expected results. Very odd way for the drive to die...its silent, but the you can barely hear it spin up for the Seagate Tools tests.

    I really don't know what happened/what is wrong with it. At least there was no data on it.
    #1 Tiake, Dec 26, 2010
    Last edited: Dec 26, 2010
  2. Highwayman

    Highwayman Extraordinary Member

    Jun 3, 2009
    Likes Received:
    Maxtor brand is owned by Seagate now, check the manufacturer's warranty via Seagate, may have a 3-5 years on it, if qualifies you might get a newer and bigger drive as a replacement.
    #2 Highwayman, Dec 27, 2010
    Last edited: Dec 27, 2010

Share This Page