drivers for pt6 mother board

Discussion in 'Windows 7 Hardware' started by DaftFader, Apr 23, 2009.

  1. DaftFader

    DaftFader New Member

    Joined:
    Apr 23, 2009
    Messages:
    2
    Likes Received:
    0
    I have just installed windows 7 64bit on my new pc but it seems that ASUS haven't made drivers compatible with windows 7 for my motherboard (P6T) and don't plan on doing so till after the retal releace of windows 7. Now as far as i can work out i should be able to just install the 64bit vista drivers but this does not seem to work for half of them ... any ideas?:confused:
     
  2. cmn

    cmn New Member

    Joined:
    Mar 17, 2009
    Messages:
    856
    Likes Received:
    45
    As far as I know no MoBo manufacturer has released Win 7 drivers yet for any of the already sold or advertised MoBos and I believe, like me, most are using VISTA drivers in compatibility mode for the devices. So, generally speaking, if your system is fit to have or already has VISTA 64 Bit OS your hardware should not normally cause any problem for on-board devices. For peripherals like Printers, Scanners, Webcams etc you must check the Support/Download site of their manufacturers for updated Win Vista 64 Bit Drivers.
    Sometimes Windows including Win 7 "behaves strangely" toward those drivers during install and that process can be frustrating . But many of us have our own "little tricks" to cross those hurdles. With some patience and different approaches you can install and make the devices work in almost all cases. In some instances you can install the driver using the Setup files [Setup.exe] from manufacturer's software in CD or downloads and following the wizards but other times the Device Manger has to be led all the way to the .INF file to accept the driver. This is from my personal experience as I have some devices that are like 3-4 yrs old which in computer world is like "senior citizens"! Anything 18 months or older becomes geriatric devices waiting for their final exits :-(

    If I can be of help please, post your specific problems in detail with any of the devices . Please include the EXACT make and Model of your MoBO & the devices so that we can try and figure out why the problem and how to overcome the issue.
    Good luck.

    Thank you for patience in reading through to the end:)
     
  3. bobkn

    bobkn New Member

    Joined:
    Feb 20, 2009
    Messages:
    174
    Likes Received:
    6
    I have a P6T Deluxe, and have run several of the Win7 X64 builds on it.

    I'm not sure what drivers you refer to.

    For the Intel chipset drivers, I suggest the 4013 or 4014 versions - older ones may require work-arounds to install on Win7. (Google them.)

    I haven't needed the SAS or IDE controllers, so I haven't tried the drivers for them.

    The NIC drivers installed with the OS have worked OK.

    The Vista X64 SoundMax drivers worked fine. (I'm currently using an Asus Xonar DX PCI-E soundcard, though. The latest beta drivers for Vista X64 work well.)

    Asus Probe didn't work on build 7000. Haven't tried it since.

    I haven't tried any of the miscellaneous Asus control/overclocking utilities. (I overclock, but just in the old fashinoned way: BIOS settings.)

    In short, I've had few problems with Win7 X64 on my P6T Deluxe. A vanilla P6T might be different, but I wouldn't expect that.
     

Share This Page

Loading...