"Enter Network Password"

Discussion in 'Windows 7 Help and Support' started by SteveMann, Sep 12, 2010.

  1. SteveMann

    SteveMann Well-Known Member

    Joined:
    Dec 21, 2009
    Messages:
    44
    Likes Received:
    1
    First, this is a small home network. No PC on the network has ever been assigned a password. I am trying to install a NAS box, and after entering the default username/password for the NAS box, Windows Security pops up with a "Enter Network Password" box.

    What "Network Password" is Windows Security asking for?????
     
  2. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    It wants the username and password you created in the NAS box.

    Windows networking always asks for the u/p of the TARGET machine, never the one you are sitting at.

    Also, unless that NAS is running Win7, you may have to switch over to a Work Network and enable "Network Discovery" and "Uername and Password sharing" in your network and sharing options. Win7 home networking only works with other Win7 systems.
     
  3. SteveMann

    SteveMann Well-Known Member

    Joined:
    Dec 21, 2009
    Messages:
    44
    Likes Received:
    1
    Thanks for trying. I am not using Homegroups - too many non-Win 7 computers here. The Target machine is not a PC, but an NAS box from CoolMax. In network Advanced Sharing - Network discovery is on, All sharing is on, Password Protected Sharing is off, and Homegroup is off.

    I have no problem connecting to the NAS from XP, Linux or Vista. Everything is in the same IP group and masking, same Workgroup. I don't get the Windows Security message until AFTER I connect to the NAS box using the default ADMIN/ADMIN login and password. Even so, the only username and password anywhere on our network is the defaults on the NAS box. And Windows Security doesn't like them. No PC here has a password-protected account.

    I wish that I could just turn off Windows Security.
     
  4. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    I hear ya... But it will want the username and password for the NAS box, at least once per machine. From there it should remember the "credentials". Or you can add them manually at Control Panel->Credential Manager.

    I'll spare you the long dissertation about not using passwords, even in trusted LANs... I'll just say that I have several machines on a family network, all are pretty much open to the whole family but it was impossible to stabilize the network until every account was passworded. There are auto-logon tools that will take you past the username and password at boot time, if that's your concern.
     
  5. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    Try this; open up the network sharing center, click in left pane of window HomeGroup, in the next window click "view or print the homegroup password". This is the default password the 7 uses to connect computers to the network.
     
  6. SteveMann

    SteveMann Well-Known Member

    Joined:
    Dec 21, 2009
    Messages:
    44
    Likes Received:
    1
    Thanks, but no-joy. Homegroups is turned off because I have too many non Windows 7 computers on the network. I.E., there is no homegroup password.
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You may have to adjust the level of encryption used by your windows 7 machine in order to authenticate to a device such as the NAS.
    First try this,
    open the network and sharing center and choose Change advanced sharing settings from the left column, scroll down to the section that says "File sharing connections" and choose "Enable file sharing for devices that use 40- or 56-bit encryption. Save changes and reboot machine. See if that helps.
    If not post back, with the version of Windows 7 you are using and we will try another technique that may resolve the issue. It's different if you are using Home Premium as opposed to Pro, Enterprise or Ultimate.
     
  8. SteveMann

    SteveMann Well-Known Member

    Joined:
    Dec 21, 2009
    Messages:
    44
    Likes Received:
    1
    Thanks for sticking with me here. There's NO rush for a solution because I have workarounds, including FTP. It's just one of the Windows Security annoyances that *should* be easily fixed. I am using both Home Premium and Win 7 Pro. BTW, I was able to make a link to the NAS in Explorer by going to tools/map network drive and using the anonymous FTP that the NAS supports.
     
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Fine, since the Pro machine is easier, let's try that one first and see if the solution is viable for your issue. It works with some NAS devices and not with others.
    Click the start orb, and type
    gpedit.msc
    expand computer configuration
    expand windows settings
    expand security settings
    expand local policies
    select/highlight Security Options
    make the adjustments in the attached image in the right pane
    reboot
     
  10. SteveMann

    SteveMann Well-Known Member

    Joined:
    Dec 21, 2009
    Messages:
    44
    Likes Received:
    1
    That was it. (And I thought I understood LAN Manager).
    I also fixed it in the Home Premium with a registry change to LmCompatibilityLevel. Was this the fix you had in mind for the non-pro Windows 7 machines?

    Thanks very much.

    Steve
     
  11. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Yep, that was it, I have a couple more images on hand for the actual registry edits that are needed. Sometimes it's the LmCompatibilityLevel and sometimes it's the NtlmMinClientSec and NtlmMinServerSec and then othertimes it's both. Anyhow, I'm glad to hear that you were able to resolve your issue and thanks for posting back with the update regarding your problem. Hope to continue to see you around the forums.
     
  12. SteveMann

    SteveMann Well-Known Member

    Joined:
    Dec 21, 2009
    Messages:
    44
    Likes Received:
    1
    I'm baaack...

    This worked - one year ago....

    Setting LAN Manager Authentication Level and setting the Registry key “HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel” to “1” finally gave me access to me NAS box.

    But, the last time I tried to open a folder on the NAS box (not a PC, but a closed box probably running some form of Linux), I am back to square one. Nothing I do will let me access the NAS box again.

    Help?
     

Share This Page

Loading...