EPSON R280-Windows 7- Apple Airport Extreme

Discussion in 'Windows 7 Help and Support' started by mac16101, Feb 5, 2011.

  1. mac16101

    mac16101 New Member

    Feb 5, 2011
    Likes Received:
    Hello to all,

    I hope someone can help with this major printer problem. If this is not the correct area for this post, I apologize in advance please point me to where I should be, Thanks. Here is my problem: Ive got a Windows 7 Acer Aspire Laptop, 64 bit, Epson R280 printer, Apple Airport Extreme. I downloaded the latest drivers from Epson and Bonjour for Windows. Ive hooked the Epson directly to the Acer and have been printing with no problems what so ever. The problem comes when trying to print wirelessly through the airport. It was working fine a few months ago then just started acting up. I would hit print, it would print maybe one page, then start the second page and get hung up in the middle, now it will get hung up at the end of a first page. Lights are all flashing on the printer, “See whats printing” is showing an error message. Its all quit maddening.

    Things Ive done: Uninstalled, installed, reinstalled, used the original software disk, uninstalled, and reinstalled using just the current driver, uninstalled and reinstalled Bonjour. Noda! Ive changed IP addresses, port numbers, added printers, turned off bio directional printing, added new ports, deleted new ports, added and deleted new LPT ports. Ive tried everything I have found on the web that has worked for others but not for me. Absolutely nothing Ive tried works. Im getting beyond ticked and ready to throw the damned thing out. What irritates me the most is that it was working at one point. So what changed, Ive added nothing else, what could it be?? Im very stubborn, which is why I haven’t pitch this sucker. I feel Im missing something and my stubbornness is blinding me to what it is..

    Any and all advice is so gratefully accepted and needed. Also, Im PLEADING AND BEGGING SOMEONE FOR HELP……………

    Thank you all so much in advance. Mac
  2. Alex Weeks

    Alex Weeks New Member

    Mar 29, 2011
    Likes Received:
    I've been having a similar problem for a while with an Epson Stylus Photo R245. The printer would print a couple of pages and then start putting out gobbledy gook, or would print multiple copies, when they hadn't been requested, etc. Researching Microsoft, Apple and Epson did not yield any results, and similar to you there were no answers that applied on the web. As you said, the answer was staring me right in the face.

    All I had to do was go to Printer Properties --> Advanced, and then select Print directly to the printer. It turns out that the spooler was somehow adding extra characters that was corrupting the print job. The printer is now working fine from a Windows 7 machine going to the shared Airport USB printer. I also tested this using just the IP address of the Apple printer as an LPR printer, and that solved the problem there also, and also on another Windows 7 machine having the same issues.

    Hope this helps, as it has been frustrating finding a solution.


Share This Page