Error 0x80070017 - Expanding files (0%) - "Cannot install required files"

#1
I deleted all my hard drive partitions and formatted my hard drive to wipe it clean. Now when I try to install Windows 7 onto my computer, the DVD boots and the installation begins. The installation will complete the "Copying windows files" task in seconds, but sticks at 0% on "Expanding files" for about 30 seconds. I will then receive an error that reads "Windows cannot install required files. The file may be corrupt or missing. Make sure all files required for installation are available, and restart the application. Error code: 0x80070017".

I researched this error but couldn't find a resolution. One suggestion was to download my hard drive's drivers onto a pen drive and load them in the installation, but this didn't help.

I also tried installing Windows Vista and received the same problem.

The error in this case has nothing to do with the copy. I have used many different Windows 7 builds, many different DVDs, burning at different speeds, all producing the same problem.

Only when using the Windows 7 RC disc I was asked to "load drivers" as a requirement. Other builds didn't require me to load drivers.

I really don't know what to do, I just want to get my computer up and running again!
 


Last edited:
#2
i have exactly the same problem and don't know what to do.... updated bios, changed sata cables... i'm really desperated.
Can anybody help? :/
 


#3
same problam

plezzzzzzzz help me same problam
 


#4
this is my pc:
AMD athlon64 x2 7750+ 2.7 Ghz AM2 BOX
Asus m2n68-cm socket am2+
mushkin essential ddr2 pc2-6400 4 gb 2x2 gb 5-5-5-18
Seagate barracuda 7200.12 500gb SATA2
Sapphire Radeon HD 4870 512MB GDDR5 PCI-E
LG H22N Writer DVD 20x ata oem

pls anyone help >_<
 


#5
I was having similar issues; the "Expanding Files" was stuck at 0%, but i never got an error. I let it sit for a while (30 min maybe?) letting it "try" to expand, and all of a sudden it moved on to the next step, and now is working fine.
 


#6
Same issue here. I used to run Windows XP 32-bit on a 64-bit processor, so when i got win 7 i decided to install the 64-bit version. I knew this would mean a clean install, but did not foresee this problem. Basically the exact same thing happens as outlined by the OP only the particular error code I get is different. I tried re-installing Win XP and fixing registry issues and updated bios but it still happened. I'm now nuking my hard drive to try again, but don't have much faith that it's gonna work. I already ordered a new HD 'cause I don't have tim to have computer trouble when exams are coming up...

However i've heard of people who installed it on a fresh drive and still got the problem...does no one know what it could be??

Windows 7 was supposed to be smooth sailing...
 


#7
I got the same problem with upgrading from Vista 32-bit to 7 64 bit.

I burned the files i got from my pre-order onto DVD-R, and i got this error.
Apparantly its caused from burning the files onto an unsuitable disc or by burning too fast.
I take it all of you burnt ure own discs?

Im just about to test it on a DVD+R, and burning it using the slowest speed possible (2x). Ill post back if it works or not.
I hope this has helped.
 


#8
That's just it. I bought my windows 7 on physical DVDs. The home premium edition. Everywhere i've been reading about this problem and they all talk about the slow burning speed, and i'm like...mine was like this in the box...

Which makes it all the more infuriating because there's nothing i can do.
 


mACO

New Member
#9
Windows 7 install grief.

Windows 7 Home Premium
Windows 7 Removed a perfectly good working Win Xp for this install.
Selected "custom" and Win 7 indicated a format was needed. i guess that is when Xp went away.

like many others have said, install advanced to expanding files. At this point a good deal of time passed with the indicator remaining at 0%. Then the world famous Blue Screen shows up. So if there is a driver conflict, why not say so?

I tried first the 64 bit then the 32 bit. both did the same thing. My machine is a AMD, dual core 64 bit. I have 4 gig of ram installed. The machine passed Windows 7 upgrade verification with only the video card not passing. The machine is about 1 year old with a Asus M2a-VM HDMI 1.XX.

This is crazy, I installed the 7 BETA and the 7 RC on another "OLDER" 32 bit PC with no problems at all. Now I try to install the purchased 7 and I get this crap. Reminds me of the Windows ME days. Once again, the machine passed Windows 7 upgrade advisor but windows 7 will not load on this machine.

So now I am installing (try) the 7 RC on this machine to see what happens. If it locks up (yep it locked up) then I will remove every expansion card i have and then see what happens. Thanks microsoft for making the process simple. And so much for your upgrade advisor. The RC version is having the same problem with the expanding of files. There is something about the machine set up that 7 does not like. Here goes with the removal of components. This won't take long. Or better still, reinstall Xp and forget about it.
 


#10
noone has a solution for this yet? Dvds fresh out of the box same issue.
 


#11
i replaced my DVD drive with a brand new one and get a brand new error.

Windows cannot install required files make sure all files required for installation are available and restart the installation.

I think the retail DVD is corrupt
 


#12
Same problem here. I had a working copy of XP x64. I downloaded the Win7 Enterprise x64 from MSDN, burned the .iso image to a blank DVD, rebooted the machine and installed from it. I selected custom installation, deleted the old partition and created a fresh one. It stuck at Expanding Files 0% for a good few mins and then I got Error code 0x80070017 Windows cannot install the required files blah blah blah...

After reading a Microsoft KB article I flashed the latest firmware to my DVD drive but still same error. Then I found this thread and find nobody has found a solution. I don't have time to fool around with this mess and will reinstall XP x64. Great, well done Microsoft. Nice one.
 


#13
Ok so this is where I belong!
Same, retail copy, was actually out of the family pack, upgrading 32 but vista home-32bit Win 7 and I get the error code, I'm kind of scared to attempt a fresh install... Weird thing is this same disc worked on a different pc doing the same upgrade.... just weird
 


#14
I have actually managed to install a working copy of Win7 in VMware on the same PC, but I booted the virtual machine from the .iso image instead of my physical DVD drive.
 


#15
Install error with GENUINE DVD

Same thing here folks. I for god sake, PURCHASED Win7 (retail)!!!!! After 'Expanding files' step, it gives an error stating cannot install Win 7 as some of the files may be missing". I mean, Microsoft put the files on DVDs. I bought the genuine software. What else can I do???????????????
This seems to be 64-bit problem only (at least for me). I installed 32-bit version on the exact same partition and it went smooth. Microsoft MUST give a fix to this problem. This is simply unaccepatble....:mad:
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#16
Do any of you happen to have a setupact.log or setuperr.log on your systems. Should be in the Panther directory or a hidden folder that starts with $.

You all must have something in common. Maybe a bios upgrade is needed, you all have the same processor or run the same type systems. Can you check you drive to see if they are using the Ultra DMA Mode 5 setting? Multiple CD/DVD drives might be a problem, as well as multiple hard drives, unless your are RAIDing.

There is always a chance something could be wrong with the MS DVD, but others have had problems and found a way around them. Make sure the DVD is not showing signs of contamination on the shinny side. Do you have enough free space on the Hard drive for all the old and new files? How much memory do you have?
 


#17
noone has a solution for this yet? Dvds fresh out of the box same issue.
Gabe and everyone experiencing this issue,

Have you checked your hardware and hard drives? Has anyone tried, just as a test, to install Windows 7 cleanly on a new (or different hard drive) than the one he or she first received this error?

Also have you run a test on your RAM to ensure all is functioning properly?
 


#18
Do any of you happen to have a setupact.log or setuperr.log on your systems. Should be in the Panther directory or a hidden folder that starts with $.

Saltgrass- I have a folder named "$WINDOWS.~BT" in my C drive. Is this why it won't let me upgrade? It says I don't have the required files. What would this folder have to do with that?
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#19
No, that is a folder put there during the install. It is where the logs are kept during the actual install process. The setupact.log or setuperr.log or setupapi.dev.log may have indications of install problems. The last few lines, or maybe more, could hold information as to why the install stalled or failed. It does not seem to always be accurate if something shuts it down before something can be written to the log.

I do not know where Windows stores the files after they are expanded. Maybe Jessica's suggestion is because they are stored in memory and if there is a problem with that, it can't find those files.
 


Last edited:
#20
Resolved for me - different HD

I was having the same problem, I was attempting to install on an IDE drive. re-partitioned, formated etc... always the same problem. I plugged in a SATA drive that I had (loaded with info already) but it had 80g of free space, so I attempted to install on that, and kaching, that worked.

So using a new HD (SATA) worked for me.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top