Error 0xE0000100

Discussion in 'Windows 7 Installation' started by confucious, Jan 11, 2009.

  1. confucious

    confucious New Member

    Joined:
    Jan 11, 2009
    Messages:
    4
    Likes Received:
    0
    I've just burned the disc from the ISO and when I try and run setup I get:
    "The file 'autorun.dll' could not be loaded or is corrupt. Setup cannot continue. Error code is [E
    0xE0000100]"

    I have found a knowledgebase article referring to a problem installing Vista giving this error but nothing on Windows 7.

    I am running Windows Vista Business on a Dell Inspiron 6400 with a 62.4Gb C drive with 12Gb free and a 9.99Gb Recovery partition with 5.45 Gb free.

    Thanks for reading this far....

    Any help would be appreciated.
     
  2. Venoms

    Venoms New Member

    Joined:
    Jan 6, 2009
    Messages:
    36
    Likes Received:
    2
    Try to burn a new copy of Windows 7 dvd, this time at very low speed... x1
    You can also check your .iso file in a image reader like deamon tools or nero's image drive.

    Erroe code E0xE0000100 is faulty dvd... in short.
     
  3. confucious

    confucious New Member

    Joined:
    Jan 11, 2009
    Messages:
    4
    Likes Received:
    0
    Thanks

    Just after I posted I realised that I hadn't tried running as Administrator - I tried and it worked!

    Up to a point. It then failed on copying windows files... :(

    I then re-burned the CD at 1X speed and it worked fine - thanks Venoms !
     
    #3 confucious, Jan 11, 2009
    Last edited: Jan 12, 2009
  4. JerryDangle

    JerryDangle New Member

    Joined:
    Feb 24, 2009
    Messages:
    2
    Likes Received:
    0
    Win PE 3.0 - autorun.dll error

    Hi there,

    I have the same problem, except I'm trying to get Windows PE 3.0 (from WAIK 7) to work.

    The exact error I get is "The file 'autorun.dll' could not be loaded or is corrupt. Setup cannot continue. Error code is [0xE0000100]".

    I have created the Windows PE 3.0 ISO using "Run As Administrator" privileges for the batch files.

    I can successfully boot the Windows PE 3.0 image either from CD or USB drive, I get the same error with both; this would indicate to me that the issue is not to do with burning the ISO to the CD (which I did at the slowest I could - 4x).

    I have re-downloaded WAIK 7 ISO thinking that maybe there was corruption with the download - still same problem as above.

    Does anyone have any useful suggestions please?

    Thanks,
    Jerry
     
  5. jasonmac

    jasonmac New Member

    Joined:
    May 8, 2009
    Messages:
    2
    Likes Received:
    0
    The file 'autorun.dll' could not be loaded or is corrupt.

    Hello Jerry,

    I am not sure if you have solved this issue already but I ran into this issue and resolved it by not adding the sms legecy suport. The following packages worked for me in my winpe creation:

    winpe-wmi.cab"
    winpe-hta.cab"
    winpe-mdac.cab"
    winpe-scripting.cab"
    winpe-wds-tools.cab"

    I removed these packages since I will not use them and this resolved the autorun error.

    winpe-legacysetup.cab" according to microsoft this is legacy support to sms
    winpe-setup.cab" base pkg for recovery support

    Hope this helps
     
  6. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    JerryDangle,

    I had this exact same error .I burnt the ISO 4 times to cheap DVD's (which had always worked in the past).

    Then I unwrapped a brand new Fuji-Film DVD and that cured the problem.

    Also, like the other poster mentioned, burn at a slow speed.
     
  7. Dynyx

    Dynyx New Member

    Joined:
    Nov 9, 2009
    Messages:
    2
    Likes Received:
    0
    Error installing Widows 7 - Getting 0xe0000100 error. My 2 cents.

    Here's what I did:

    I had this problem occur with two different error messages.

    I had burned 5 DVDs and got the error 5 times. I had a hard time believing that the ISO from my MSDN subscriptions were all faulty as well as having that many defective DVDs. As indicated on many sites, this installation error may be caused by defective/low quality DVDs or DVDs that were burned at too fast of a speed. To test this theory I booted and tried to install from a thumbdrive that I had setup and used to install W7 to my DVD-less netbook. I got the same error - again. At this point I doubted the DVDs were at fault. Perhaps time to look at the disk in the laptop.

    As an aside, a friend, just recently, who had just bought herself a copy of W7 and asked that I help her install it as well as upgrade her memory. During the course of starting the installation, I ran into a issue similar to the one mentioned above. Convinced that the issue had nothing to do with the DVD, I examined the partition table and found it littered with hidden and reserved partitions used for system restores, etc. Since this was going to be a clean install and I had backed everything up, I threw caution to the wind and nuked all the partitions. When I retried the install, poof, it worked. I even had it create the primary and 100MB reserved partitions.

    For this install I was updating my wife's Dell Inspiron 1420 laptop, that I had upgraded to Vista a while back. So, applying what I learned in the paragraph above, I pulled out and booted from my tech disk and nuked the partitions. Then I re-started the install and, poof, it worked.
    So it stands to reason that a fresh installation of W7 has some issues with existing partitions on the hard drive. Any other similar experiences?
     

Share This Page

Loading...