Error 10016 restarting

Discussion in 'Windows 7 Help and Support' started by Noobie7er, Oct 9, 2012.

  1. Noobie7er

    Noobie7er New Member

    Joined:
    Oct 9, 2012
    Messages:
    8
    Likes Received:
    0
    Hi guys.
    My event viewer keeps showing error 10016 causing my computer to crash.
    I've seen the tutorials but I don't know what caused my problem; I don't run any servers.
    Sometimes, it crashes without error 10016, though I think its the main problem. Help?

    Error 10016: The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID

    {C97FCC79-E628-407D-AE68-A06AD6D8B4D1}

    and APPID

    {344ED43D-D086-4961-86A6-1106F4ACAD9B}

    to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    That error doesn't normally cause Blue Screens. Microsoft seems to think it is a nusiance error.

    If your system is actually crashing, are you getting dump files and have you checked the BSOD forum for help?

    The error can be stopped by changing the access to that service and it seems to be related to the PnP IP Bus Enumerator with some remote devices, like multifunction printers.
     
  3. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
  4. Noobie7er

    Noobie7er New Member

    Joined:
    Oct 9, 2012
    Messages:
    8
    Likes Received:
    0
    I don't understand his instructions :(
     
  5. Noobie7er

    Noobie7er New Member

    Joined:
    Oct 9, 2012
    Messages:
    8
    Likes Received:
    0
    @Flavius
    For your error 10016 don't you have any simpler instructions?
    I can't find HKLM lol on regedit. =(
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If you want to fix the error, we can go through it. Use the link below and let us know where you run into problems.

    I'll have to look for the reference I had the other day, but it isn't that hard. I did have to go into the registry to change some permissions, so we will have to see.

    Are you running SP1? It seems the error has stopped for me, even on this new install.
     
    #6 Saltgrass, Oct 10, 2012
    Last edited: Oct 10, 2012
  7. Noobie7er

    Noobie7er New Member

    Joined:
    Oct 9, 2012
    Messages:
    8
    Likes Received:
    0
    It doesn't cause blue screens, It just restarts. And also, my system is actualy restarting.
    Can you give me some advice on how to change the perms?
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    OK, this is a two part process. Allow access to the IPBusEnum to change Launch permissions.

    Before we start, the warning about making changes to the registry might make your computer unbootable should be noted

    Use the Winkey + R to open a run command and type comexp.msc then hit enter.

    Once the Component Services dialog is open, expand the folders Component Services\Computers\MyComputer then click the DCOM Config. (see Attachment)

    In the Window, find IPBusEnum and right click and select properties, Security tab. You can see the options are greyed out. We will have to change the permissions in the registry for that AppID, so close the Computer Services dialog.

    You can get the GUID number you need to use for the registry search from the General tab of IPBusEnum, or your error message.

    Now open the Registry (regedit.exe). Search for the GUID number under Keys and you will find the entry under AppID.

    HKEY_CLASSES_ROOT\AppID\{344ED43D-D086-4961-86A6-1106F4ACAD9B}

    Right click the number and select permissions, Advanced button, Owner tab.

    Select Administrators(... and click apply. Your Administrator should now be the owner. OK your way out of the dialog.

    Reopen the properties and give your Administrator full control and click apply then OK back out.

    You should now be able to reopen the Component Services dialog and give the Local Service Local Launch permission. Close the dialog.

    You can now change the ownership back to Trusted Installer. Open the Registry again and go back to where you set the ownership. Click the Other Users and Groups link and type

    nt service\trustedinstaller


    and hit check names. TrustedInstaller should show in the window, so hit OK. Then select TrustedInstaller on the Owner dialog and click Apply, then OK out.....

    If you want to change the Admin permission back to what they were, do it before you change the owner, then OK out and go back to change the owner.

    Since I do not have the error after some update, I assume, I cannot verify the setting is the correct one. Wait for the to stop, and if the error does not stop, you might try some other permission changes for the IPBunEnum. If something doesn't look right about the procedure, ask...
     

    Attached Files:

Share This Page

Loading...