Error 5: Acces denied (Unable to create directory)

Rani

New Member
#1
[FONT=arial, sans-serif]Hello everybody, I am just new here and was wondering if you guys might have a solution for this problem that has been bothering me alot:

If I run the setup of new program I recently get this error message more and more: Setup was unable to create the directory "C:users\gebrui~1\AppData\local\temp.... Error 5: Acces denied."

I looked quite a while around the internet and found some people with exactly the same problem but the solutions didnt work out for me. I tried turning AUC both on and off, I tried running the file as admin (My account is admin also), I even tried to install it with my virus scanner turned off but nothing seems to work;(

I would be really happy if someone might know a solution for this frustrating problem,
Thanks alot!

[/FONT]
 


zvit

Honorable Member
#2
Welcome to the forums.

Since your UAC is turned off, and you are running the install as Admin (because you already are admin), it seems like a permission issue and not a UAC issue. Try this:


  1. Create a folder name "Temp" under C:\ // This step is important, the folder has to exist.
  2. Right click the Computer in Start menu and select Properties
  3. Click Advanced System Setting
  4. In System Properties windows, click Advanced tab
  5. Click Environment Variables button
  6. Under User variables list, double click TMP
  7. Change Variable value: from "%USERPROFILE%\AppData\Local\Temp" to "C:\Temp"
  8. Try to install.

You can also test by creating a new Admin user and install something there.
Tell us the results.
 


#3
Welcome to the forums.

Since your UAC is turned off, and you are running the install as Admin (because you already are admin), it seems like a permission issue and not a UAC issue. Try this:


  1. Create a folder name "Temp" under C:\ // This step is important, the folder has to exist.
  2. Right click the Computer in Start menu and select Properties
  3. Click Advanced System Setting
  4. In System Properties windows, click Advanced tab
  5. Click Environment Variables button
  6. Under User variables list, double click TMP
  7. Change Variable value: from "%USERPROFILE%\AppData\Local\Temp" to "C:\Temp"
  8. Try to install.

You can also test by creating a new Admin user and install something there.
Tell us the results.
this worked for me..thanks for your help..
 


#4
this didnt work for me, i have the same settings as him :eek:
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.