Error for extra Internal: "You need permission to perform this action"

#1
So here's what's going on. I have just recently installed windows 7 for the third time now (following build updates ect). I have two hard drives in my computer, one labeled C:\ where windows 7 is installed and the other labeled D:\ which is the drive in question. When I try to copy a folder from one part of the D:\ drive to another, it simply says, "You need permission to perform this action." Now I've down a bit of poking around trying to find some answers, but nothing has proved to work. I had absolutely no problems when I was using the hard drive first time around with windows 7 (after moving up from Vista) and now the last two times I've reformatted (clean install) I have to Take Ownership of my drive so I can access and use the files.


I'm not really sure whats going on and what I should do, I've tried taking ownership (doesn't work) I've tried using an admin account (same), I made sure I had admin rights, I've tried disabling UAC, and I've tried taking ownership of the file I was copying plus the directory I was copying the file too.

Basically what I end up having to do is make a new folder, take ownership of the folder (because I can't do anything with the folder until I take ownership because I have no permission to access it), then I can copy my files into the folder.

Now to further whats going on here, it also doesn't happen everywhere on my drive. It only happens on folders that I included in my Libraries of my first Windows 7 installation. So I can make a folder on the root of my hard drive and I can do what I feel like. But if I make a folder in, say, my music folder or pictures folder I have to go through this giant fiasco just to use it.

Now this is pretty frustrating as reformatting the drive at the moment isn't an option (or I would do that) because its 800GBs full of files and I can't put the files anywhere else. Soooooo any help at all would definitely be appreciated. Thanks!
 


zigzag3143

Honorable Member
Microsoft MVP
#4
Boh

Who is the owner of the folder you are having problems with?

Ken
 


#5
Boh

Who is the owner of the folder you are having problems with?

Ken
I am the owner of the folder. (I believe) I've been through all the settings in securities and permissions and set myself as the owner with all admin rights, but that doesn't seem to work.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.