eSATA drive won't appear on system although it would previously

Discussion in 'Windows 7 Hardware' started by Centerpunch, Aug 25, 2011.

  1. Centerpunch

    Centerpunch New Member

    Aug 25, 2011
    Likes Received:
    About a week ago, I replaced the optical drive on my fairly-new Samsung notebook (model NP300-V5A-A02US) with one of these:

    All it really does is turn the internal SATA data connector for the optical drive into an eSATA socket.

    It worked well for most of last week. I was able to hotswap and use Clonezilla with the external disk. Now, however, it won't work at all. The external drive doesn't show up in anyway, either in Device Manager or the HotSWAP! utility.

    Initially, I thought the adapter cable had just pulled loose, as there's nothing securing it to the notebook's internal connector except friction. Nope, that wasn't it.

    I tried everything else I could imagine: swapping the adapter cable for a new one, trying a different eSATA cable to the eSATA external drive, even trying a different eSATA external drive.

    I know the external drives are OK, because they work fine on another computer, connected via either eSATA or USB 2.0/3.0.

    I've tried both using the HotSWAP! utility, and having the drive connected when the machine powers up. The drive doesn't even show up in the list of disk drives in BIOS.

    If I reinstall the original optical drive, it works fine. So I'm reasonably sure the internal SATA connector is still OK.

    I'm really stumped on this one. Any ideas?

Share This Page