Ethernet won't connect unless Wireless connects first.

Discussion in 'Windows 7 Networking' started by SumDumGuy, Mar 21, 2010.

  1. SumDumGuy

    SumDumGuy New Member

    Joined:
    Mar 21, 2010
    Messages:
    10
    Likes Received:
    0
    Hi,

    My hardwired Ethernet card will not connect to the internet when using my wireless router.
    Currently, to resolve this: 1) the Ethernet Card must be disabled; 2) the Wireless card must then be enabled; then, 3) once the Wireless card has found the internet, it (the Wireless card) must be disabled, and finally, 4) the Ethernet card must be re-enabled (at which point it can then be used to access the net).

    Please note:

    1) I have tried this with two different Ethernet cards (different brands) so it almost certainly cannot be either their hardware or software.

    2) A second computer (laptop) can connect directly to internet through a hardwired connection to the router. Therefore, it is not the router. (The laptop is also Win 7, but DID NOT install the latest updates.)

    3) This is a dual boot system: Win 7 and XP. Under XP, the hardwired connection works flawlessly.

    4) The Ethernet/Hardwired connection worked under Win 7 for about a week, then the above problem arose on the Wednesday morning after Patch Tuesday (Automatic Updates ON) 03-17-10.

    System Specs:

    OS: Win 7 Home Premium.
    Ethernet: Marvell Yukon 88E8039.
    Wireless Card: Broadcom 802.11g Network Adapter.
    Router: Netgear Wireless-N 150.

    All have latest drivers.

    Many thanks to anyone who may have insight into this rather esoteric problem.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If you suspect that the problem was caused by recent updates that may have installed a new driver for you ethernet adapter, then perhaps you might open device manager, select the problem adapter, then right click on it and choose properties, select the driver tab and choose the roll back driver button. If it's greyed out, then that's probably not the problem.
    With the wireless adapter disabled and the wired card plugged in, can you provide a screen shot of the ipconfig /all for the wired card?
    Do you seem to be receiving proper ip information from the router for the wired connection?
    Have you tried a release and renew (ipconfig /release and then ipconfig /renew)
    Have you tried to flush DNS (ipconfig /flushdns)
    Have you tried the network troubleshooter with only the wired card enabled? What information, if any does it provide?
    Have you tried assigning static values to the ip addressing scheme for the wired card?
    You say that you have tried two different wired adapters. Is this an embedded ethernet card? If so, when you tried the addon card, did you disable the onboard card in the bios, during this test?
     
  3. SumDumGuy

    SumDumGuy New Member

    Joined:
    Mar 21, 2010
    Messages:
    10
    Likes Received:
    0
    Hi Randy,

    Thank you so much for the great reply. I have already:

    1) Rolled back the drivers (no joy)
    2) Gone through Network Troubleshooter (when the wireless card hasn't been enabled/disabled, etc. to get to the net, the Wizard just looks and provides nothing; but when the wireless card HAS been enabled/disabled, thereby allowing the Ethernet to see the net, the Wizard goes through quite a bit of checking, says everything is super, THEN can't find anything).
    3) Pinged the router through the hardwire connection (works fine).

    I shall follow your instructions regarding all the IPConfig stuff, the DNS flush and the screenshot and get back to you regarding the results.

    Also, I actually DIDN'T disable the onboard card in the BIOS, only in Windows Device Manager. I shall also give that a shot.

    Thank you again for taking the time and trouble to share your wisdom and experience. It is truly appreciated (and I believe really makes a significant difference in the world!)

    Adam
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    The only reason that I mentioned disabling the integrated card in the bios, is that I vaguely remember another post from a member that was having a problem with an integrated Marvell Yukon card on an ASUS MoBo, with 4 gigs of ram, and the only resolution for him was to purchase a second card (different Manufacturer) and use the MoBo Bios utility to disable the onboard card. So I just thought I would throw that out there for your consideration.
     
  5. SumDumGuy

    SumDumGuy New Member

    Joined:
    Mar 21, 2010
    Messages:
    10
    Likes Received:
    0
    Hi Randy,

    Thank you again for all the wonderful suggestions. As per your instructions, I did the following:

    1) ipconfig /release and then ipconfig /renew
    2) ipconfig /flushdns
    3) assigning static values to the ip addressing scheme for the wired card

    In all the above cases, the same thing happened:

    SCENARIO A: Rebooting the computer with the changes and the modem and router left ON - The Ethernet could access the net.

    SCENARIO B: Rebooting the computer with the changes and also rebooting the modem and router from a cold/OFF state - The Ethernet could NOT access the net.

    Also, as you instructed, attached you will find a screenshot of the Ipconfig /all when the Ethernet cannot access the net. (I also did a comparison of this to when it can, and there seems to be not difference).

    Thank you again for sharing your time and insights.

    All the best!
     

    Attached Files:

  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Do me a favor and plug the following IP address values into the DNS area in your adapter's properties, IPv4 properties
    Preferred 8.8.8.8
    Alternate 8.8.4.4
    Turn your computer off and then restart it and see if that makes any difference.
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Sorry also disable IPv6 while you are adjusting the properties of your adapter
     
  8. SumDumGuy

    SumDumGuy New Member

    Joined:
    Mar 21, 2010
    Messages:
    10
    Likes Received:
    0
    Hi again Randy,

    Thanks for writing back. I inserted the values you instructed. Sadly, no joy.

    Afterwards, however, I went through the wireless card to get on the net, then re-enabled the Ethernet and captured the latest Ipconfig /all. It was identical to the previous one posted, except there is now a 0.0.0.0 entry in the default gateway above the old 192.168.1.1. (I attempted to enter this into the IPv4 Default Gateway setting, but it would not allow it...)

    I realize that this problem must seem rather esoteric, and I wish to once again express my gratitude to you for taking the time and consideration to brainstorm upon it. I also completely understand that it may be so odd that it is insolvable, and if we have run out of options, that is cool too.

    Once again, thank you! You are really making the world a better place!
     

    Attached Files:

  9. SumDumGuy

    SumDumGuy New Member

    Joined:
    Mar 21, 2010
    Messages:
    10
    Likes Received:
    0
    Resolved!

    Hi Randy,

    Thank you!

    You were right. The solution WAS to assign static values to the IP addressing scheme. Previously, I had done it solely to the IP address, and Subnet mask, but no luck. However, when I also assigned the default gateway and DNS server addresses to the router, then success.

    I am certain that this is probably what your instructions indicated in the first place, it just never occurred to me that these also fell within those parameters.

    Once again, thank you so much for sharing your patience, experience and wisdom!
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Excellent. Good to know you have it resolved and thanks for posting back with the update
     

Share This Page

Loading...