.EXE files not associated with explorer (or something)

Discussion in 'Windows 7 Help and Support' started by Robert Costello, Nov 26, 2010.

  1. Robert Costello

    Robert Costello New Member

    Joined:
    Nov 26, 2010
    Messages:
    4
    Likes Received:
    0
    Hey there,

    I foolishly agreed to help my boss get some malware off his daughter's laptop, specifically Win 7 Antimalware 2011. I managed to get rid of it using Spyware Doctor but now when I click on any .exe it goes to the "open with" window. If I right click and open as administrator it opens as normal.

    I found this: Broken EXE Association
    But there is no specific info for Win 7.

    I'm guessing a registry entry is missing or messed up but would love more info before I start poking around in there. Thanks in advance.

    Just say no, kids.

    -Windows 7 Home Premium
    -64-bit
    -Toshiba Satellite L500-19X
    -Pentium Dual-Core T4300 - 2.1GHz
    -4GB RAM
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Probably the safest thing to try first would be a restore point prior to the issue first occurring. This should get your registry values back to where they were at that point. Assuming that you have tried and exhausted this route. Then you may find this article helpful
    Fix or Restore Broken .EXE .LNK .COM Association Caused by Virus | Raymond.CC Blog
    or perhaps this one
    File association fixes for Windows Vista
    I have noted that some people have reported success using one or the other of those two resources. Of course manually create a current restore point before attempting or applying any registry repairs or fixes.
    Also consider following up what you've already been able to accomplish with Spyware Doctor by running Spybot S&D as well as MBAM , download, install, update signatures, boot into safemode and fun both, removing anything they find.
    Hope this helps and keep us posted.
    Good Luck
    Randy
     
  3. Robert Costello

    Robert Costello New Member

    Joined:
    Nov 26, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks for the help. System restore worked, I hadn't tried running it as administrator yet.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Good work, that's excellent news. Glad to hear that you were able to resolve your problem and thanks for posting back with the update to your thread. Welcome to the forums and we hope to continue to see you around.
    Good luck
    Randy
     

Share This Page

Loading...