Experiencing very slow internet browsing/download speeds

Discussion in 'Windows 7 Networking' started by Desync, Dec 22, 2009.

  1. Desync

    Desync New Member

    Joined:
    Dec 21, 2009
    Messages:
    2
    Likes Received:
    0
    Hello, I had Windows 7 Ultimate 64 bit installed on a new computer for about a week and a half or so, and the internet was running fine with normal download speeds etc. All of a sudden, a couple of days ago my internet started slowing down gradually and eventually to 56k-like speeds. I was able to temporarily fix it by power cycling but it would just happen again. Now it's gotten to the point where even power cycling or anything else has no affect, it's basically slow all the time. The computer in question is connected to the internet via ethernet (connected from modem into router, and out from router to computer) and there's another computer upstairs which is connected is connected wirelessly with a USB network adapter and it is doing fine.

    I've reinstalled the OS already a few times, as well as trying a fresh install of Windows XP, but I'm still faced with the same issue. I usually get around 1.2 Mbps downloads but now it barely hits 40kbytes, and the websites take forever to load or they won't load at all. I've also tried downloading the latest drivers, as well as sticking with default windows drivers, still no luck. Safe mode with networking is still slow, and even connecting directly to the modem makes no difference, as well as using a different web browser. Really tried to figure this out for the longest time and it's getting pretty frustrating.

    Motherboard: Gigabyte MA-785GM-US2H
    Network Adapter: Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)

    Any and all help would be greatly appreciated, I'm hopeless!
     
  2. NateIAm

    NateIAm New Member

    Joined:
    Dec 22, 2009
    Messages:
    4
    Likes Received:
    0
    I have been experiencing the same problem testing for full deployment to my 60 user domain. I note that my NIC defaults to 10Mbps/Full Duplex when using Auto Negotiation (my backbone is 100 Mbps). If I put my old XP box back on using the same connection to the backbone I get 100 Mbps.

    If you are not in a domain try going into your NIC properties, select configure and click on the link speed tab and change the Speed & Duplex setting from Auto Negotation to 100Mbps full duplex.

    I tried to this in my domain but it destroys the trust relationship between the workstation and domain.
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Desync:
    Try going here they have a Win 7 driver and what they are calling a Win7 64 and 32 bit Auto Installation program, which may help http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false
    you may also want to look into a firmware upgrade for your particular router, you didn't mention the manufacturer of model number, but it's genereally a good idea to have everything running the latest and greatest. Hope this helps.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Desync:
    You may also want to try this, I found it somewhere back when I was having some fits with Vista

    1. Right-click “cmd” icon and select “Run as Administrator“.
    2. Run the following command to check the enabled offload tasks:
    netsh int ip show offload
    This is what I get

    Interface 1: Loopback Pseudo-Interface 1
    Interface 11: 192.168.1.69
    ipv4 transmit checksum supported.
    udp transmit checksum supported.
    tcp transmit checksum supported.
    tcp giant send offload supported.
    ipv4 receive checksum supported.
    udp receive checksum supported.
    tcp receive checksum supported.

    3. Run the following command to disable all Task offloads:
    netsh int ip set global taskoffload=disabled (This should disable all the offloads)
    4. Disable and Enable the NIC
    5. Check if all Offloads are disabled from an elevated command prompt.
    netsh int ip show offload
    If you've done this correctly the results shouldn't show any offloads
    This is what I get
    Interface 1: Loopback Pseudo-Interface 1
    Interface 11: 192.168.1.69
    Could possibly help, shouldn't hurt to try
     
  5. NateIAm

    NateIAm New Member

    Joined:
    Dec 22, 2009
    Messages:
    4
    Likes Received:
    0
    I finally found an updated driver for my NIC and it solved the problem. I am using Intel, so you may need to check with the manufacturer of your NIC.
     
  6. victha

    victha New Member

    Joined:
    Dec 31, 2009
    Messages:
    2
    Likes Received:
    0
    Hi,

    I had the same problem with Windows Server 2008 R2 and now with Windows 7 enterprise (testing). The following worked for me. But i'm not sure in what order or if both need to be done.

    In Internet Explorer go to Internet Options. On Content tab under Feeds and Web Slices disable all settings. Then under Connections -> LAN Settings, untick Automatically detect settings and tick User a proxy server for your LAN but do not specify any address. Just leave port to 80.

    Like i said this worked for me.

    Good luck
     

Share This Page

Loading...