Explorer.exe Crashes, then remote procedure failed

#1
Hey all, just joined because I'm having a bit of a problem with Windows 7, Build 7100 (sorry that I don't know much more than that; not really a computer person a lot of the time).

Now since I installed W7, I've had the occasional glitches or bugs that one would expect, including Explorer.exe crashing a whole bunch when I use too much memory (which is surprising considering I have 4 gigs of ram plus a quad-core cpu), but not really a huge problem.

However, two days ago when Explorer.exe crashed, even after it got turned on again, I couldn't open any fle folders. Instead I got the following message:

"The remote procedure call failed and did not execute."

Well, restarting or logging off my machine fixed it, but the same problem occurs whenever Explorer.exe crashes.

Now, I'd like to think that I'm not an idiot and I looked online for help. People seemed to recommend going into services.msc, finding the Remote Procedure Call, and starting it up set on automatic. The problem? It IS started and set on Automatic and the problem persists. So I am honestly stumped and would like some help if anyone knows what the problem is.

I also tried to track it down to recent updates my computer may have made and I uninstalled Silverlight, Windows Live add-ons and etc., but no luck there. Anyone have any ideas?
 


#2
same Problem here...

does anybody have a solution for that!!
 


reghakr

Essential Member
#3
Hello and welcome to the windows7forums,

Hit the Win key + R, now type services.msc.
Scroll down until you see that both Remote procedure entries are started and set to Automatic.

Was this an upgrde or a "clean" install?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top