External USB hard drive freezes or says it's empty

Discussion in 'Windows 7 Hardware' started by YakooMarkTwo, Dec 21, 2009.

  1. YakooMarkTwo

    YakooMarkTwo New Member

    Joined:
    Dec 21, 2009
    Messages:
    2
    Likes Received:
    0
    I'm using:
    OS - Windows 7 Ultimate 32 bit
    CPU - AMD Athalon XP 2400+ 1.99GHz
    RAM - Kingston 2.00 Gb
    MOBO - VIA VT 8366a Apollo KT266a

    the problem I have is an 1Tb Western Digital external USB drive. It will work fine, but every now and then I can't access anything on it. I can browse the folders, but they all say they're empty. I try to disconnect it with the Safe USB Device Disconnect thing, but it says "this device is in use". I try to unplug USB cable, replug - no luck. same with power cable. The only thing that gets it back in gear is rebooting windows.

    A side note that may or may not be related, Windows 7 will often have processes that don't respond and CAN'T be killed in Task Manager (you MUST hard reboot). I ran ComboFix and TuneUp Utilities 2009 Registry Cleaner - which seems to make that happen less often, but it still happens and usually has to do with a program that's accessing a file off my external drive (all my music, movies, pictures are on that).

    I've read plenty of posts around the net about windows 7 and usb hard drives having similar problems, but no solutions.
     
  2. MBLe

    MBLe New Member

    Joined:
    Dec 24, 2009
    Messages:
    2
    Likes Received:
    0
    Hi, I have exactly the same problem.
    My system is:
    ACER M3641
    OS - Windows 7 Home Premium 64-bit
    CPU - Intel Q8300 Quad Core2Quad 2,5Ghz
    HDD - 750Gb
    RAM - 4,0Gb

    My Seagate external USB HDD of 1Tb gives exactly the same problem. It freezes sometimes and shows empty folders.
    It did work normal under Windows Vista 64-bit.
    The same happens when I connect my Nikon D90 camera with 8Gb flash card. It starts copying and does it for a few files and then stops. Only a complete reboot solves the problem.

    This is really anoying! Does anyone know anything about this problem and how to solve it?
     
    #2 MBLe, Dec 24, 2009
    Last edited: Dec 24, 2009
  3. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    I've got 2 different 1T Western Digital externals. The My Book Essential works with no problems. The My Book Pro is actually 2 matching 500G drives that could be configured for RAID but mine is not. what I have noticed is that putting PC in Sleep seems to bring up the problem. It clear the problem I usuall power it off then reboot then plug back in. I suspect there may besome type of driver/timeout issue. I don't see a new driver listed. This also shipped formatted for a Mac. This was a problem on RC also. I've got Ultimate 64 bit.
    Joe
     
  4. erdie

    erdie New Member

    Joined:
    Dec 29, 2009
    Messages:
    2
    Likes Received:
    0
    I recently purchased a 2tb external hard drive, this was to copy stuff from my other external hard drives. Everytime I connect the 2 external hard drives to my laptop and start copying files from one to the other, I get a message saying that the files(s) do not exist on the drive (this is always the drive I am copying to) and I get three options to try againg, cancel or skip. Everytime I have opted to cancel the copy and try again. I then encounter another problem, when I try to delete the few files that have been copied to the new drive I am getting the same message saying that the file can't be deleted as it doesn't exist on the drive.
    I have also noticed that my computer seems to be very sluggish and slow when the hard drives are attached. I cannot even unplug the devices and when I try to safely remove them I get a message saying that they can't be removed at the moment as they are in use. If I just take out the usb, they are still shown in 'my computer' under the hard drives section. The only option is to reboot my machine.
    I thought that it may have just been a compatibility issue with the external hard drive and windows 7. So I took the new external hard drive back to the store and got a different make and model. But I am still having the same problem.
    I tried the to do the same thing on a friend's vista laptop and it worked perfectly, so this shows that nothing is wrong with the external hard drives.
    As a last resort I am copying files to my laptop hard drive and when it is full I am copying it to another external hard drive. Even the copying process seems really slow, I noticed a couple of days ago when transferring trying to
    I am seriously considering installing Vista on my laptop, and not many people say that.

     
  5. dilip

    dilip New Member

    Joined:
    Aug 19, 2010
    Messages:
    4
    Likes Received:
    0
    I have save some picture and video in a folder in my external hard drive. The hard drive was also used as image back up. IT WAS o.k FOR SOME MONTH, BUT RECENTELY I have notice that the folder was missing. The image file which is shown as VHD file can be open but every thing is stored except that particular file.Can any friend help me?
     
  6. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    Did you try deleting the driver, powering down the PC unplug the drive? Then boot back up and plug in the drive again. Did you look on the drive maker's site in their forums?
    Joe
     
  7. dilip

    dilip New Member

    Joined:
    Aug 19, 2010
    Messages:
    4
    Likes Received:
    0
    Thank you for reply my friend. The manufacturer name of the external hard drive is Buffalo mobile launcher. LET ME TRY AGAIN.
     

Share This Page

Loading...