External USB HDD Issues

Discussion in 'Windows 7 Help and Support' started by bdafrog2, Jul 4, 2009.

  1. bdafrog2

    bdafrog2 New Member

    Mar 22, 2009
    Likes Received:

    I am running Windows 7 64-bit Build 7100 on a Gateway DX4640 (Intel Core2 Duo CPU/4 Gb RAM). I have two internal HDD (Maxtor and WDD) that are working fine. Operating System has been running well since the beta release. I am having a strange problem with all USB HDD (Seagate FreeAgent Xtreme (1 Tb- brand new), two different WD MyBook(500 Mb) and LaCie RugF (250 Gb)). I have tried each individually, all USB ports and through a hub. The drives install fine, get assigned a drive letter and show up in explorer. I can copy to and from the drives initially, but then the copy to fails, as in "File No Longer Available". The copied files are ok after reboot and power cycle of the HDD. I've tried explorer and TeraCopy. The drives still show up in explorer, do not have any marks in Device Manager(could find no driver updates) but are now non-functioning for read/write. I have disabled USB power management, tried using the Administrator account and set permissions wide open. I've disabled Virus software (ESET) no difference. All drives work great on another computer running XP SP3 or Tablet PC edition. USB Printer and Scanner work just fine.

    Thanks for any advice.[/FONT]
    #1 bdafrog2, Jul 4, 2009
    Last edited: Jul 4, 2009

Share This Page