F5D7000 E troubles.

Discussion in 'Windows 7 Networking' started by Louis, Oct 13, 2009.

  1. Louis

    Louis New Member

    Joined:
    Oct 13, 2009
    Messages:
    10
    Likes Received:
    0
    WLAN card, F5D7000 E troubles.

    Hi, I've been searching for ages and must have tried about 15-20 different drivers/methods, but to no avail.
    Basically I know this hardware works with windows 7 as I've read people who have got it working but their methods don't seem to work for me!

    I have tried:
    atheros_v2.0.0.74,
    f5d7000v8_ww_2.00.09 (belkin, the manufacturer of the card),
    Broadcom can't remember where but have seen a few places where this is said to work,
    and f5d7000v8_ww_2.00.09 (Realtek, from intel, the motherboard's manufacturers website).
    and a variety of methods.

    Could someone please shed some light into why I'm such a failure with this?! I remember it was a huge pain to get it working with vista, but not quite this bad.

    In case it helps my WLAN card is F5D7000 E
    My motherboard is an 'intel desktop board'
    It's 64bit windows 7.

    Regards, Louis.

    Edit: Providing a little more info.
    The light on the card doesn't come on, doesn't recognise it, didn't try to add new hardware, I don't think.
    When I used the intel method of the realtek driver It installed but couldn't find the hardware and asked me to turn it on if it had a master wire (can't remember the exact words).
    The card works fine on vista, but frankly vista sucks.
    If anyone has any ideas or if I can proide more useful information please let me know, I don't want to give up on 7!
     
    #1 Louis, Oct 13, 2009
    Last edited: Oct 15, 2009
  2. Ryender

    Ryender New Member

    Joined:
    Oct 15, 2009
    Messages:
    2
    Likes Received:
    0
    Having the same issue here too
    same pci adapter.
    same issues

    Mine just recognizes as Unknown device, no drivers (even with the vista 64 compatible drivers installed)
    Wont load, does nothing when plugged into ethernet to try and get the wireless drivers.

    (desktop is too far away from router to plug in via ethernet)


    =[
     
  3. Louis

    Louis New Member

    Joined:
    Oct 13, 2009
    Messages:
    10
    Likes Received:
    0
    Hi, Does anyone know if there's any sites that contain info that would be helpful? I've looked what seems like everywhere but must've been looking in the wrong place as I've drawn up nothing but duds. I'm keen to resolve this problem and am no stranger to putting in hours of search time but have run out of places to look.
    Regards, Louis.
     
  4. SBUK

    SBUK New Member

    Joined:
    Oct 25, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,

    I had the same problem with the Belkin f5d7000 V7000UK card.

    To resolve this you will need to identify exactly which card and version you have (I had to look at the sticker on the card itself).

    Then you need to download the correct driver from here Belkin United Kingdom : Support : Network Adapters
    This is the UK website so you will need to visit your country of residence's version if outside UK
    Make sure it's the same Version as the card (you will get quite a few options) Don't run it yet.

    To get around it not installing (only compatilble with blah blah blah) you need to right click on the file, select properties and go into the compatibility tab. Check the box, (I ran it as a vista sp2 file) click ok then right click on the file again and run as administrator.

    At this point the driver should install and your card, work.
     
    #4 SBUK, Oct 25, 2009
    Last edited: Oct 25, 2009
  5. Louis

    Louis New Member

    Joined:
    Oct 13, 2009
    Messages:
    10
    Likes Received:
    0
    Hi and thanks for the reply, Unfortunately this didn't work. Do you mean I can only run windows7 in 32bit with this card? I'm sorry I didn't really understand the last paragraph.
    I have some additional information in it helps:
    Belkin F5D7000 E, Version 1100ea
    Serial 752000294
    Chipset; AR2413A-001
    64bit windows 7,
    Thanks for trying though :]
    Louis.
     
    #5 Louis, Oct 27, 2009
    Last edited: Oct 27, 2009
  6. SBUK

    SBUK New Member

    Joined:
    Oct 25, 2009
    Messages:
    6
    Likes Received:
    0
    Hi,

    Sorry about that, I will try to clarify.

    This worked for me in 64 bit win7 for my F5D7000 G Version7 card and should hopefully work with yours.

    When you have downloaded the driver install file from Belkin you will find trying to double click and install it normally, will give you an error saying the driver is only comapatile with win95, 98, me, 2000, vista etc and will not list windows 7, therefore it will not be elegible to install.

    You can get around this by right clcking on the driver install file bringing up the context menu and left clicking on properties from that menu.

    This will bring up the properties box which will have several "tabs" at the top. Click on the compatibility tab and it will take you to the compatibility options.

    Check the box that allows you to run the file as though it were on another version of Windows (I chose vista sp2) and click ok.

    Next right click on the driver install file again, and this time click on Run as Administrator in the context menu that appears.

    You should now be able to double click on the file and install it via the on screen prompts. Give it a reboot and you should find the card in the system stray bottom right where you can set-up access to the net.

    Please let me know if you need any further clarification.

    SBUK
     
  7. salessa

    salessa New Member

    Joined:
    Oct 27, 2009
    Messages:
    4
    Likes Received:
    0
    Thank you.

    But this did not work for me.

    I own a F5D7000 Wireless G Desktop (V 7021.de) which encludes a Realtek 8185L WLAN Chip.
    Following your description (Installing in Vista compatibility Mode SP2, installing as admin) resulted still in Error Code 31.
    After installation and restart .. nothing happend. No config screen as usual or anything else. After looking into Device Manager this could be found :

    "Es wurde Treibersoftware für das Gerät gefunden aber es ist ein Fehler aufgetreten.
    Das Gerät funktioniert nicht ordnungsgemäß, da Windows die für das Gerät erforderlichen Treiber nicht laden kann (Code 31)"
    Sorry for any mistakes while trying to translate -> "Device drivers have been found, but an error occured. Device does not function as specified because Windows was not able to load the neccessary drivers"

    Strangest thing is, i use Win7 HP 64bit. There were no problems with RC 1 built 7100 64bit. Using RC 1, the drivers had been installed automatically through Update Manager. And they did work brilliant.

    A folder "Belkin/F5D7000_V7021" does exist in "program files", obviously the correct Drivers... but nothing works.
    Sry.
     
  8. SBUK

    SBUK New Member

    Joined:
    Oct 25, 2009
    Messages:
    6
    Likes Received:
    0
    This must be quite frustrating.

    Belkin have really dropped the ball on this one, they've had plenty of time to sort thier drivers.

    I hope you manage to find a work around for this. You may want to try some German (?) forums as there must be differences other than localisation in the DE versions of the drivers.

    Hopefully this work around will be useful to other people
     
  9. Louis

    Louis New Member

    Joined:
    Oct 13, 2009
    Messages:
    10
    Likes Received:
    0
    Sorry, I forgot to include that I did change the compatibility, and ran as administrator on almost all my attempts. It's a pretty ancient card, and I agree from the sheer volume of threads across the internet Belkin have made a mess of this.
    I understand it's the chipset rather than the card you need to correlate to the driver, but AR2413A-001 Just leads me to dead ends on all my searches. I am about ready to give up on belkin and go buy a linksys card or something that will actually work and or have support.
    Thanks very much for your continued efforts, they are really appreciated!
    Louis.
     
  10. Louis

    Louis New Member

    Joined:
    Oct 13, 2009
    Messages:
    10
    Likes Received:
    0
    Hi again, I'm guessing that this WLAN driver is a no hoper, could someone recommend a good WLAN card that is under £20?
    The cheapest one i was looking at is:
    TP-LINK Wireless 54MB PCI Card - Aria Technology
    Although I'd imagine I would have the same problems if I bought this card...
    The other one that looked promising is:
    Linksys Wireless-G PCI Adapter - Aria Technology
    I have heard very good things about linksys WLAN cards and their compatibility.
    If anyone else has any good suggestions they would be more than welcome, I just don't want to buy something else and have the same problems again!
    Cheers, Louis.
     
  11. salessa

    salessa New Member

    Joined:
    Oct 27, 2009
    Messages:
    4
    Likes Received:
    0
    Hello

    Your guessing seems to be correct.
    2,5 months later Belkin still did not manage to supply working drivers for my Wireless Desktop G.
    Look at their Website, last Update in 2007, it's a shame.
    Neither has REALTEK... tried every probably fitting Chipset driver.

    Bought a TP-LINK TL-WN951N PCI Adapter.. working fine, no problems and better connectivity than Belkin-Crap.

    Belkin? No thanks, never again.
     

Share This Page

Loading...