File and Printer sharing

Ween

New Member
#1
I just got a laptop with Windows 7 and am having trouble connecting it to my desktop (Windows XP) workgroup. I added the laptop to the workgroup and the laptop shows up in my Network places on the desktop but when I click on it, I get an error message saying the path cannot be found. Also, the desktop does not show up on the laptop as a network place (as part of the workgroup)

I ran the trouble shooter on the laptop and it said "File and print sharing resource is online but it isn't responding to connection attempts." Any ideas on how to share the files and printers?
 


stueycaster

Millennium Celebration Award Winner
Premium Supporter
#2
Did you make sure they have the same workgroup name? XP wants to call it Mshome while W7 calls it Workgroup.
 


Ween

New Member
#3
Yes, they both have the same workgroup name. We have been using this workgroup between a destop using XP and a laptop running Vista and they worked fine. Now I cannot get the Windows 7 laptop to show up as a networked computer on the xp desktop or the xp desktop to show up as a networked computer on the window 7 laptop.
 


#4
I am having exactly the same issue. I have a XP workgroup containing two XP computers, this allows device and file sharing without issue.

I have now purchased a netbook which has Windows 7. I have changed the worgroup name on the Win7 netbook to be the same as the XP workgroup.

On the XP machines under My Network Places | Entire Network | Microsoft Windows Network | [workgroup name] I see the names of all three PCs including the new Win7 one, but unlike the other two when i clcik on this I get an an error message saying the network path was not found.

On the Win 7 PC I see only 1 computer (the win7 one). I do see under Media Devices the name of the XP laptop but when i click on it all that happens if media Player Opens, exactly the same as when I click on the Media devise which has the same name as the Win7 PC.

Under network infrastructure I see my ASDL router/modem.

Can some please offer some assistance/advice on how to solve this issue.
 


stueycaster

Millennium Celebration Award Winner
Premium Supporter
#5
All I had to do to set up my network was this.

Go into "Advanced Sharing Settings" and make sure Network Discovery, File and printer sharing and Public folder sharing are turned on and Password Protected sharing is turned off in both the Home or Work and Public profiles.

I changed my workgroup name to Mshome.

Then I right clicked on the files I want to share and selected Share with "Specific people". Then I added "Everyone" to the list of people to share with.

Then I went into XP and set up the network there. You might need to set up the network on your XP computers again. They might need to be set up to network with your new computer.

Then I waited 15 minutes before trying it. They don't usually start up immediately. That's all there was to it.

Once in a while our network doesn't want to start up. It's almost always right after my wife's laptop is first started up. Whenever this happens I can always jump start it by typing \\192.168.2.4 (her computer's IP Address. Yours will probably be different.) into the Address bar of Windows explorer. Notice the back slashes. Then it always works good til the next time my wife shuts off her computer.
 


#6
Network problems between Windows 7 and XP

Hi,
I have 2 pc's in a netwerk and a SMC router (4 ports and Wireless)
Both computers are connected to the Router with cable and wireless.
From Both computers I can acces the internet (Router is also gateway)
So I have 4 IP-adresses:
- XP 192.168.200.100 (wireless)
- XP 192.168.200.103 (LAN)
- W7 192.168.200.101 (Wireless)
- W7 192.168.200.102 (LAN)

When I do a ping from the XP pc to the windows 7 PC (..101 or 102) I get a reply from the network adapter of the WIndows 7.
But when I do the same on the Windows 7 PC to the XP pc (..100 or 103) I don't get a reply.
Why ??
 


#7
My Solution

I cleared my issues by going into the firwall software on all my PC and added the relevant connections as 'trusted connections'.
 


#8
Communication between W7 and XP

I had a similar problem as MBaeten but after reading PaulWSmith's post, I went into my Control Panel | Firewall | and looked at my settings. I had "Don't Allow Exceptions" box checked. After unchecking, I can see both directions ! Thanks PaulWSmith
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.