Files in External USB HDD are not being shown

Discussion in 'Windows 7 Help and Support' started by akpuvvada, May 13, 2012.

  1. akpuvvada

    akpuvvada New Member

    Joined:
    May 13, 2012
    Messages:
    4
    Likes Received:
    0
    I have a Western Digital 1 TB External USB HDD.
    I have used it for some time.
    One day, I was copying files from my laptop to the USB HDD.
    It was taking for ever. So, I tries to cancel it. It wouldn't cancel. So, I disconnected the USB HDD by pulling the USB chord.
    From that day, it is not working.
    When I connect it will show it as a local-disk, but not show any details like size or name of the drive. It takes forever to open right-click menu and properties. Disk Manager takes for ever to show the list of drives. If I double-click on the drive, my whole system becomes slow and windows explorer hangs.

    If I restart my system in Safe mode, it will show the drive in Disk Manager as RAW and it gives me an option to format.

    I do not want to format it as I have some very important files in it.

    Is there a way to recover the data and the HDD.

    Please help.
     
  2. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
  3. akpuvvada

    akpuvvada New Member

    Joined:
    May 13, 2012
    Messages:
    4
    Likes Received:
    0
    I have tried EASEUS Partition Recovery and testdisk.

    They also hang. No use. For some reason, the drive is not readable or the partition is not accessible. It just doesn't show that message. It just hangs.

    Is Recuva different?
     
  4. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Yes, Recuva is different, like all software are different, but I doubt it will solve your problem. You may try it, the only cost is some time...

    You could try a partition program that works from BIOS, like MiniTool Partition Wizard Home Edition , or GParted GParted -- About, they will show you if the partition / info really exist. However, they won't do any more, except perhaps giving you the chance to move the info to another place --- that is, if it exists. It's a bit complicated.

    Have you tried the disk with another computer? Sometimes USB is a bit tricky, like computer technology in general. Try connecting it to a friend's machine? I've had problems with USB sticks, copying and pasting... suddenly I've been told there is nothing, or formatting has failed, or whatever.

    Hope you get it running. :)

    Of course, theres the possibility that your saves / formatting are corrupted, or that your disk is broken. These things do happen.
     
    #4 Pauli, May 15, 2012
    Last edited: May 15, 2012

Share This Page

Loading...