Firefox doesn't detect Flash Player 11

#1
Flash Player 11.1.102.62
Firefox 10.0.1
Windows 7 x64 SP1

I downloaded the Flash Player installer from the official site and ran it. It downloaded the files and installed Flash. But whenever I try to view Flash content in Firefox, it claims that I don't have FP11 installed, offers to install it for me, tries to and then fails and says I must install it manually, which simply takes me back to Adobe's Flash Player site, where I had already downloaded the installer from!

I just tried Firefox with a new profile and it doesn't work that way either.

I have lately been using a debug version of FP 10.3, but got sick of the constant debug error messages I got when I tried to play videos and was hoping that 11 would simply work this time around. I uninstalled 10.3 before installing 11.

FP 11 does work properly in Google Chrome 16.0.912.77m and Internet Explorer 9.

If anyone can shed some light on this mystery, I would be grateful.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#2
If you look at the Firefox addons, in the plugins section, you should see Shockwave Flash. You may have to enable it, but if you do not see it then Flash may not be installed.

What version of Firefox are you running?
 


#3
I'm using 10.0.1 as stated in my first post.

Flash Player 11 is installed, but isn't listed among my Firefox plugins.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Have you seen the following reference?

Managing the Flash plugin | How to | Firefox Help

I don't know why it won't install on your system. I have run into the problem of having to do a manual install because the auto install does not work.
 


#5
I did the manual install (downloaded the setup file from Adobe's site and ran it). It said it was installed on my system. It is listed under Add/Remove Programs, but still Firefox won't detect it. Chrome does detect it and runs it, so I know it is properly installed.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
Did you read the comments about there being two versions of Flash, an ActiveX and Plugin? I assume you downloaded the Plugin version, but if it did not install in Firefox, even with a manual successful install, it might be the wrong one or something else is stopping it.

You did get the UAC permission popup when you ran the install?

Since you were running a debug version of the player, I will assume you have been having problems with it. Perhaps uninstalling it completely and installing just the Firefox Plugin version would help.
 


#7
The plugin is what I've been trying to download. When Firefox tries to do it the normal way, it always fails and directs me to Adobe's site. When I go to the site, it detects the version for Firefox. I download and install it. It installs successfully and works with Google Chrome.

No UAC prompt because I disabled UAC.

I just now uninstalled/reinstalled Firefox and still it won't use FP 11. I had uninstalled FP 10 before installing 11.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.