Fix for Windows 7 Internet Disconnect when download or doing heavy traffic

Discussion in 'Windows 7 Networking' started by sogoku, Nov 18, 2009.

  1. sogoku

    sogoku New Member

    Joined:
    Nov 17, 2009
    Messages:
    4
    Likes Received:
    0
    Hello to all.
    I've been having trouble with Windows 7 Internet connection after freshly installed it not long ago. My Internet connection kept giving me a yellow sign error (disconnected from My computer to the Router) when I download or transfer large files.
    I had to go to Change Adapter Setting and Disable, then Enable the adapter to get the connection back on again.
    So, after searching and reading numbers of posts related to this issue, unfortunately not many people found the fix for this problem. Today, I just finally fixed this, and would like to share this with people who had the same problem with me.

    It seems the problem is mostly for people who is running Windows 7 with nVidia chipset.
    So here is the fix.
    1) Go to "Network Connection" and click on the Network NIC card you are using, select "Properties"
    2) Go to "Configure", "Driver", and click on "Update Driver"
    3) Click on "Browse my computer for driver software", then click on "Let me pick from a list of device drivers on my computer"
    4) Select "NVIDIA nForce Networking Controller (Microsoft)" and click "Next". Follow the instruction and install the driver for the NIC.

    5) Go to "My Computer" and "Uninstall or Change a Program", look for "NVIDIA Network Manager" or something like that and Uninstall this program from your Computer. Follow the instruction and Restart your computer.
    6) You have solved this Windows 7 Disconnect problem.

    Sorry for my poor English. Hope this will help people who are also looking for this fix.
     
  2. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    It's great to see someone come here and offer a solution they have found. It probably happens less than 1 out of every 100 posts.

    Here is another solution to inernet/connection lags.

    Go to Task Manager /services /services and Disabled the Function Discovery
    Resource Publication service. It has been found to conflict with another service.

    Note: Windows 7's new "HomeGroup" connectivity requires this service.
     
  3. sogoku

    sogoku New Member

    Joined:
    Nov 17, 2009
    Messages:
    4
    Likes Received:
    0
    Hi, Thanks for your input.
    As for the Unidentified Network problem, I went to the NIC properties and uncheck these things:
    -Internet Protocol Version 6 (TCP/IPv6)
    -Link Layer Topology Discovery Mapper I/O Driver
    -Link Layer Topology Discovery Responder

    After that, all worked fine now.
     
  4. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    How did you figure that out? I remember the IP Helper service is ipv6 because I included it as a service to turn off.
    Very few ISP's offer a native IPv6 network to home users.


    I wounder if simply disabling that service would have also fixed your problem?
     

Share This Page

Loading...