Floppy drive detection in Win 7 x64 booting UEFI

Discussion in 'Windows 7 Help and Support' started by Rick Dee, Nov 2, 2012.

  1. Rick Dee

    Rick Dee Active Member

    Joined:
    Nov 2, 2012
    Messages:
    6
    Likes Received:
    0
    I installed Windows 7 x64 Professional on a GPT partition and am booting through UEFI. The floppy controller is detect but the floppy disk drive itself is not detected.

    Does anyone know why this is?

    I know I am not the only one with this situation.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Are you running a motherboard with a floppy controller on board? If so, I suppose you have it enabled in the bios?

    I haven't seen one of those controllers in quite a while. If it is an older system, there may not be a driver for the device. I use a USB floppy drive when I need to use a floppy, for whatever reason.
     
  3. Rick Dee

    Rick Dee Active Member

    Joined:
    Nov 2, 2012
    Messages:
    6
    Likes Received:
    0
    The motherboard is an ASRock 990FX Extreme4 which has a floppy controller and a floppy connector on it.

    Yes, I have the floppy enable in the UEFI BIOS and I can boot a MS-DOS disk from it.

    If I boot Windows 7 x64 in the BIOS mode on a MBR disk, the floppy disk is detected.

    If I boot Windows 7 x64 in the UEFI mode on a GPT disk, the floppy disk is not detected but the floppy controller is.

    UEFI.ORG tells me the UEFI BIOS is not programmed correctly.

    ASRock claims it is Microsoft's fault. I guess ASRock is referring to the boot .EFI file but I can't get any answer from Microsoft.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    That is interesting, you would think ASRock would make note of that situation in the manual.

    I was thinking possibly it was related to the formatting of the floppy. Since the UEFI does not like extended partitions on a secondary internal or external hard drive during boot, maybe there is a correlation. My USB floppy seems to work fine.

    All I might suggest is to disable the controller in device manager. Then reboot and re-enable it after rebooting to see if it might be picked up then. You may have to do a device search to find the controller, but since a floppy doesn't act like a USB device, it may not help. If it doesn't, boot without a floppy in the drive, if you have not already done so.
     
  5. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    I'd say it's not really a Microsoft issue. It's a BIOS issue. Any flaw is within the BIOS = ASRock part. Microsoft = Windows comes along after the basic boot.

    Question: why do you need a floppy?
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The UEFI Bios I have seen also have options during boot to allow Legacy/UEFI OpRoms. You might try changing any of those to the other option, and play with anything that mentions legacy enabled or disabled.
     
  7. Rick Dee

    Rick Dee Active Member

    Joined:
    Nov 2, 2012
    Messages:
    6
    Likes Received:
    0
    I appreciate all the questions and suggestions, but the fact is I purchased a motherboard with a floppy controller and a floppy disk cable connector. This is absolutely nothing in the literature and the user manual cautioning about the floppy disk drive not being detected on a Windows 7 x64 OS booting under UEFI on a NTFS formatted GPT disk.

    The floppy disk is enabled in the UEFI BIOS or else I would not be able to boot from a MS-DOS disk. The floppy disk drive is recognized when booting Windows 7 x64 on a MBR disk under BIOS.

    ASRock insists the problem is a Microsoft fault and Microsoft will not respond to any inquiries about the situation.
     

Share This Page

Loading...