Freezing/BSoD in Win 7 64


New Member
I built a new computer in June, and since then it's been periodically freezing up while doing nothing in particular. Recently I've been getting full-on blue screens of death, sometimes as many as five a day. I don't even know where to begin to diagnose something like this, so if anyone can point me in the right direction I'd be very grateful.

I've attached a zip file of the output from Captain Jack's diagnostic tool, but here's the short overview of my system:

Windows 7 64-bit
Microsoft Security Essentials

Processor: AMD Phenom II X6 1055T
Memory: 2 x 2 GB G.Skill Ripjaw series DDR3 1600
Video: onboard Radeon HD 4290
Motherboard: Gigabyte 890GPA-UD3H

Thank you.



This driver needs to be removed from the system:

GVTDrv64 GVTDrv64.sys Tue Sep 05 03:10:02 2006
Please uninstall Gigabyte's utilities, such as Easy Tune to get rid of it.


New Member
I uninstalled all of Gigabyte's software except the Gigabyte Raid Configurer, but the driver still seems to be there. Is there something else I should try?


New Member
Alright, looks like it's gone. Thank you -- it's great of you to do this.


New Member
Damn, I've still got issues. It froze again just now and I had to restart. No BSoD this time -- is there a way I can dig up some data on this incident?

No bsods happening now is a good thing. If it continues like this, much improved.

We can look at the system further. You can type msinfo32 in the start menu then hit enter. File | save on the screen that opens. Zip the saved file and attach to a post.


Looking over crash dumps again for the moment, I've noticed this older driver could use an update:

whfltr2k whfltr2k.sys Fri Jan 26 03:04:37 2007
It's for your "Advanced Wheel Mouse". You can visit the manufacturer's site for the latest driver for it.


You can update your Realtek HD Audio driver from the following link. It's not that old but good practice to do so anyhow:

RTKVHD64 RTKVHD64.sys Tue Dec 08 05:20:05 2009


And for now, you can go to C:\Windows\System32\drivers to rename gdrv.sys to gdrv.BAK if it's still there at all. Reboot.

Last edited:


New Member
Attached nfo file.

Edit: I'll also look into the other things you mentioned.



New Member
Update on this... I had another BSoD yesterday, and the freezes have continued regularly. I tried analyzing the DMP file myself, but it was quickly apparent that I haven't got the slightest idea what I'm doing. So I've uploaded the latest one... any new insights?


Let's keep on updating drivers that need it. It can only do some good or actually fix the issues.

This will update your Realtek lan driver to June 4, 2010

Rt64win7 Rt64win7.sys Thu Aug 20 12:05:06 2009

Then visit this link for your motherboard:

While there, download and install the latest Chipset and USB 3.0 drivers too. There's even a new bios you can flash to, which would be good. (Only for bios, make sure you have the same revision motherboard. Go to the correct page if not. The drivers will be the same, however.)


I have a guess of my own here that this driver may be posing an issue:

athrx    athrx.sys    Wed Jul 08 20:49:13 2009
It is a driver for your wireless lan (network) card. does not have any later driver as this is already the latest. You can try removing the card itself while powered off as a last resort kind of thing to see how it goes without it.


The latest crash has actually involved CCC.exe which is the Catalyst Control Center for the ATI video card. It does not definitively mean that it was the cause, but could be at least partially responsible. I'd make sure there is no overclocking going on and that the card is running within spec with relation to heat.

If all else fails, I would use Driver Sweeper from to completely remove everything ATI it can find. Then, download the latest driver from to install again. But this time, do not install the normal way. Install through the device manager and leave CCC off.

Here's how:

Run the .exe to extract the driver to C:\ATI
Close the installer immediately after extraction is completed to there. Do not let it install any longer in any way.
Open the device manager. Right click on the video card. Choose update driver software. Browse my computer. Let me pick. Have disk. Browse.

Then navigate to the folder inside C:\ATI which has the .infs. Double click on the one with CL in its name then hit ok. Hit next and it will install.


If you still have problems after even doing this, then I would test the memory modules with only one stick installed at a time using Memtest86+.

Multiple passes will be necessary. If any show even one error, then that stick is no good and should be returned to the manufacturer for replacement.

While dealing with memory, it would be good to use CPU-Z to check which exact modules are in use. Then visit the manufacturer's site for the voltage it should be set at. Adjust you bios manually for the voltage with what you find. It may require more power.

Good luck and please keep us updated.

Last edited:
Ok, everything is updated now, including the Realtek driver (I can't remember exactly what happened, but it didn't work last time).

I actually find it encouraging that CCC might be involved. I'm using onboard video at the moment, and a new Nvidia card should be here in a few days. Maybe I'll strip out everything ATI-related once that arrives and give you an update afterward.

The wireless card was one of the last things I installed, and the freezes were happening long before it. But now that I think about it, the blue screens started around the same time it went in. That's another thing I'll look into.

The memory has passed a few tests from the built-in Windows memory diagnostic, but since everyone recommends Memtest86 I'd better give that a shot. Is it necessary to test one stick at a time initially, or just to narrow the problem down to the bad stick if an error comes up?

Thanks for your patience.

You're welcome.

Yeah, it's good to give an initial scan with Memtest86+ for some passes with all memory in. If memory is an issue, it would probably find something like this. However, there are many cases where it takes the isolation of a module - running it alone to test - to cause it to show errors.

The Windows memory diagnostic is an extremely basic test and is not really definitive by any means. Even multiple passes with Memtest86+ does not mean 100% there is no memory error. It just means in those passes there were no errors then, while being tested. After many passes, you can start to assume RAM is well though, especially when done one stick at a time.

The memory situation has me a bit confused. This was the RAM I ordered: 2 x 2 GB of F3-12800CL9D-4GBRL. It's DDR-1600, but when I built the machine, it defaulted to DDR-1333 speed, which I expected from reading reviews beforehand. On the first day, I switched the voltage from 1.4v to 1.5v where it belongs and changed the memory clock from X6.66 to X8.00, which brought the speed to where it was supposed to be. I thought so, anyway.

I noticed when I did some initial passes with Memtest86+ (no errors, by the way) that it was claiming the memory was still running at 666 MHz/DDR-1333. I took your advice and installed CPU-Z, which also said it's running at 666 MHz. The SPD tab gave the modules a max bandwidth of PC3-10700 (667 MHz) and identified their part number as F3-12800CL9-2GBRL.

That's not the number I expected... in fact, I can't even find any mention of that model on G.Skill's website. The 12800 in the number seems to indicate it's still supposed to be DDR-1600, though.

One other thing: I'm not sure how I should read the timings table in this program. Are these the timings the RAM is meant to be set at at each of these speeds? In that case, the current timings aren't correct for either 666 or 800 MHz. I'm guessing this isn't helping my situation.

I've attached screenshots of both tabs. Any idea what to make of this?



I see a few problems. Mostly that command rate. It needs 2T instead of 1T as it is currently set.

To get it to work at the rated speed, you'd probably be best off allowing the motherboard to fully configure everything. If you take away all of your settings and let the motherboard setup the memory automatic by spd, it should set everything including the command rate well.

You'll probably be well off after doing this. It should change the fsb to dram ratio, thus making the modules work at intended speed. You could check on things with CPU-Z once you get back into Windows again. Make sure the memory tab matches what the spd tab under XMP-1600 shows.

I reset everything in BIOS to optimized defaults, which puts it at at 1333 9/9/9/24/33/1T. If it makes things stable I guess I can't complain too much, but I'd like to get the speed I paid for. Would it be wise to manually set everything according to the XMP-1600 timings CPU-Z shows? (If I manually set the clock speed to 1600, the settings it suggests are 11/11/11 something).

Last edited:
Your motherboard is setting it well for the modules you have.

If you look on the spd tab programmed by the manufacturer, it shows the modules' maximum bandwidth is 667 MHz. (If pushed to anything over this, it is considered an overclock and can easily bring about instability.) If the optimized defaults are now set and there are no crashes/freezes, you're good to go and nothing else to worry about. We've successfully fixed the problem then. :)

You have PC3 10700 memory = 667 MHz.

Now it may be different than what you bought. If that bothers you, you'll have to take that up with the retailer.

But as of now, your pc is set optimally for what you have. (The difference is not really going to be noticeable in anything.)

If you want to test your memory bandwidth, open a command prompt. Type this command then hit enter:

winsat mem

I'm dredging this one up again. This seems to be a hardware issue now rather than a Windows issue, but I thought I'd come back since I've gotten such good help here already.

The updated story: a G.Skill tech has confirmed that my memory is what it's supposed to be (the 4GBRL product number is for the kit, while 2GBRL is for the individual sticks). It is DDR3-1600, and ought to run stably at that speed.

As it turns out, after a lot of trial and error, I've found that it doesn't run stably at any speed.

However, I eventually discovered something odd. When I was testing the sticks individually with Memtest86+ (20-plus hours of tests with no errors, by the way), I found that when the sticks were placed in two particular slots (slots 2 and 4 on the board), the program would identify them as running at only 200 MHz. When placed in slots 1 and 3, it said they were running at 800 MHz, which is what I had expected based on my configuration.

Later I found that - lo and behold - the system was stable when I had only one stick in slot 3 (or it was for at least 5 days, the longest I've ever tested it for). It crashed quickly when a stick - either stick - was in slot 2 or 4.

My good slot/bad slot theory was kind of dented, though, when I tried the sticks together in slots 1 and 3 (in single channel mode). It crashed in about a day.

All of this appears to rule out the memory, and implicate the motherboard. Gigabyte seems ready to sign off on an RMA, but before I go through the hassle and expense of doing that I thought I'd look around one last time for more insight.

Is there any alternative explanation for why the system, and Memtest86+, would behave this way? As far as I can tell, Memtest86+ is the only program that sees the memory in slots 2/4 running slowly. CPU-Z always sees it at the speed I set in the BIOS.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.