full AHCI mode causing slow startup?

Hellooooo peopluuh

My beautifull litlle PC is having startup problems! oh noes! :O

Well, I got only SATA drives, so I changed some registry value (yea i did that after windows install, my bad) and changed all Bios option that had anything to do with IDE or so to AHCI. It's runnning like that for about 2 months, no changes in hardware or whatever, but what a noticed lately is that the drive usage indicator (well you know that thing on the front panel of the pc right?) takes about 30 seconds to start up/to start accessing the drive (you can hear it as well). So the PC kind of does simply nothing for those whole 30 seconds, I just think that part should be skipped :D

Well other things you might need to know, I have noguiboot enabled and that's it.
I hope there are some good AHCI/SATA junkies out here that can help me :redface:


btw, just look for my computer specs in my profile, got them all updated.

To not spam this forum with threads, I've got 2 monitors hooked up, working fine.
But... everytime my desktop background changes I get laaaaaaaaaaaaag, in like everything, when watching a movie, or playing counter strike, it's just annoying so it would be great of you got some solution :)

Last edited:


Senior Member
Maybe one of the hard drives is dying? Try running chkdsk and scan for bad sectors.

hmm, no problems during the test, though I know that my 2nd HD is a couple of years old and not perfect anymore, ill try starting up without that drive to compare.


Senior Member
Any update on this?

No :p
i reinstalled windows 7 because of some admin permission issues, well and i didnt really take the time yet to watch startup xD
yea me lazy :D


Senior Member
So its working better now, or are you still having the same problems?

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.