G700 Mouse and all mouses not working well on system

Discussion in 'Windows 7 Help and Support' started by honsbeek, Apr 4, 2011.

  1. honsbeek

    honsbeek New Member

    Joined:
    Apr 4, 2010
    Messages:
    144
    Likes Received:
    2
    Hi there ,

    First I thought it was just a problem with the Logitech G700 gaming mouse I have but then I try to switch to another mouse an the exact same problem persisted.

    PROBLEM:

    When I click left mouse button I almost always get double click command. And dragging is almost impossible, when drag selecting texts or url's on notepad , although the mouse button is fully clicked in , the process gets interrupted.

    Like I said I get this now when trying out another mouse , so this most definitely excludes the G700 to be faulty.

    I wonder what is causing it , it started to happen when I changed my system , and am now using a new board ASUS p8p67 with i2500K , and 4 gig RAM.

    Mouse mouses are wireless , and the g700 is 2.4ghz and the other mouse is a little less specs I believe .

    Thank you kindly

    Ralph

    PS , the same happens when the G700 is linked to its usb cable.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Assuming the all batteries are good, it would seem to be either a mouse driver problem, or a USB driver problem.

    Have you tried different USB ports?

    Have you tried using the mouse dialog to set the mouse characteristics? Have you tried the Logitec mouse drivers?
     

Share This Page

Loading...