Gadgets - weird issue?

#1
Hey guys, i'm having a real strange problem with Windows Desktop Gadgets on my Windows 7 Ultimate installation.

Currently, every time I log in to Windows, or try to open the Gadgets program, it crashes. Yet, for some reason, when I install a gadget from Microsoft's gadget page, the gadget installs, and the rest of the gadgets run fine...at least until I next log on, and then the same process repeats.

Anyone know how to fix this? UAC is enabled, i've ran sfc /scannow without luck. I've also taken ownership of the gadget folders and tried deleting the Weather gadget, also to no avail.

Any help would be appreciated! :D
 


#2
Hey guys, i'm having a real strange problem with Windows Desktop Gadgets on my Windows 7 Ultimate installation.

Currently, every time I log in to Windows, or try to open the Gadgets program, it crashes. Yet, for some reason, when I install a gadget from Microsoft's gadget page, the gadget installs, and the rest of the gadgets run fine...at least until I next log on, and then the same process repeats.

Anyone know how to fix this? UAC is enabled, i've ran sfc /scannow without luck. I've also taken ownership of the gadget folders and tried deleting the Weather gadget, also to no avail.

Any help would be appreciated! :D
I have a related issue. I upgraded from Vista Ultimate 64 to Windows 7 Ultimate 64, fairly successfully. However, even though gadgets appear to work (such as calendar and clock) those that require access to the internet (stocks, weather, and even the wireless/wired gadgets) can't seem to do so, even thought I have no problem browsing the web with Firefox, etc.

Is there a service I have to start in order to allow the gadgets to access the internet?

Thanks:confused:
 


#3
UPDATE: I found out what the problem is, I opened Event Viewer in Administrative Tools to see what was going wrong when I opened it. Turns out my mshtml.dll is corrupt, and needs to be either replaced or restored. I know you can get a mshtml.dll from the Windows 7 DVD, but it's not the same version as the one I have.

My version: 8.00.7600.16444
Windows DVD version: 8.00.7600.16385

If I replace this file (which I have already backed up and made a System Restore point), will it alleviate my problems, or will my computer just hit the wall?

Thanks in advance.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
If you can delete it, scannow will replace it. You may have to take ownership and move it out of the folder.

Have you tried just uninstalling all the gadgets currently in the system and reinstalling them.
 


#5
Gadget access to internet?

I can get Gadgets to run in Windows 7 Ultimate 64, but none of them which require access to the internet seem to be able to access the internet. Are there permissions which need to be set or services that need to be started to allow this? (I've upgraded from Vista Ultimate 64 and have no other internet issues.)
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
wsk1234, you may want to start your own thread since your problems do not seem to be related.

vastblue, when I say uninstall, I mean from the gadget window, right click.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.