Game graphics badly aliased

Discussion in 'Windows 7 Graphics' started by sliderule, Jun 6, 2009.

  1. sliderule

    sliderule New Member

    Joined:
    Jun 6, 2009
    Messages:
    12
    Likes Received:
    0
    I've noticed that some games (Plants v Zombies & Port Royale II specifically, for now) are pretty extremely aliased - all the curves have jagged edges, and some fonts are almost unreadable. I do have the latest non-beta nvidia drivers, and ClearType seems to be working fine otherwise. Is anyone else having this problem?
     
  2. dam89

    dam89 New Member

    Joined:
    May 8, 2009
    Messages:
    372
    Likes Received:
    8
    I had that problem in sniper elite - ATI Radeon x1100. I updated to the latest beta catalyste Control center and its fine now. The Graphics performance has doubled since vista as far as i can tell.
     
  3. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello sliderule

    In order to troubleshoot your problem we need to know more detailed specs of your system hardware.

    1. Go to Start > Run, and type msinfo32, look under the Components section for hardware identification
    2. Go to Control Panel > Device Manager and look for any entry that has a yellow flag beside it
    3. The manufacturer name and model number of your PC, if applicable
    4 .Download System Information Viewer) 3.36
    5. The exact make and model of your motherboard would be of great help
    6 Please fill out your computers specs in the User Control Panel (User CP) here on the site as well. It will then appear next to your name. look at my posting and you'll see the drop-down arrow.
     
  4. sliderule

    sliderule New Member

    Joined:
    Jun 6, 2009
    Messages:
    12
    Likes Received:
    0
    1. Did so - information is now in my profile.
    2. Nothing has a yellow flag.
    3. Custom built machine - see profile
    4. Did so - very helpful.
    5. Asus P5B-Deluxe
    6. Got it. Anything else?
     
  5. sliderule

    sliderule New Member

    Joined:
    Jun 6, 2009
    Messages:
    12
    Likes Received:
    0
    Ok, I found out some more info - I think it has to do with display scaling. Here are some comparisons from Plants vs. Zombies. Both are screenshots cropped to 640x480, I didn't do any scaling at all. I used PvZ because it has a menu setting to use 3d acceleration or not.

    First, without 3d acceleration. This is how it's supposed to look.
    Second, without acceleration.This is a good example of the aliasing I was talking about. Notice that the 640x480 shot takes up much less of the screen, so it seems like maybe it's a smaller image getting stretched out to the higher resolution. Does that point in any interesting direction?

    I've tried to change the scaling mode in the nVidia control panel, but after I click the "apply" button the selection resets to "Use my display's built-in scaling."
     
  6. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello sliderule ,

    Sorry for the delayed response.

    Are you using the official Nvidia drivers fro their site?

    I'm sure you're away that many games revert to a lower resolution
     
  7. sliderule

    sliderule New Member

    Joined:
    Jun 6, 2009
    Messages:
    12
    Likes Received:
    0
    Yes - as I mentioned I was using the latest non-beta nVidia drivers, and I have recently tried the beta drivers with no luck.
    I found this thread, which describes exactly the problem I'm having.

    Re. lower resolution: yes, that's exactly what's happening: the games are trying to run at a lower resolution, and the mechanism for scaling them up to the native resolution is apparently bad, and I'm unable to try different scaling modes in the nVidia control panel.
     
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Yes, I see exactly what you mean, I cannot change mine either.

    Try right-clicking on the executable, choose Compatibility Mode and change to a different OS or disable some of the other check boxes until you get a clear picture.
     
  9. sliderule

    sliderule New Member

    Joined:
    Jun 6, 2009
    Messages:
    12
    Likes Received:
    0
    Did so - was able to get Port Royale 2 working by disabling compositing, but Plants v. Zombies is still bad. Hrm.
     
  10. DrConstrat

    DrConstrat New Member

    Joined:
    Sep 15, 2010
    Messages:
    54
    Likes Received:
    0
    And still, MONTHS later - its still a problem. Its amazing nobody fixes these bugs :-(
     

Share This Page

Loading...