Windows 7 Games folder in the Start menu

#1
I like the way that newly installed games are put there in a centralized location rather than hunting the start menu for who made it etc.

The only issue I've been having the past, say week, has been that when I click "Games", it takes about 20 seconds for all of the icons to load and essentially freezes my PC for that time. After that, I can click on whatever I'd like and it works fine.

Just wondering if anyone else has run into this issue or has any idea on this. I'm thinking it may be my SATA HD throwing a fit but I just don't understand why it would work fine for months and then start acting weird. The only game I actually have on that HD that it pulls info from is WoW. Possibility there?
 


#2
Not to bump this but does anyone know what's up with the Games start menu folder?

One thing I think I may have seen is that the description for each of the games is pulling somewhere from the web. It looks like that may be why it bogs out when it's opened.

Anyone know of this being the way it works or ... ?
 


#3
It could be a few things causing this. If I were you I'd check over my RAM and processor, but if it's hardware related it's most likely your harddrive. Did you try virus scanning? I'd say it's probably a hardware problem, but the only way to make sure would be to allocate some space off your harddrive, then dual-boot Windows 7 and test it from there. If it's still acting up on a fresh install, chances are it's a hardware problem. Make sure your tower (or laptop) is clean of any dust, and try disconnecting your harddrive and re-connecting it to make sure nothing has loosened up.

PS: After writing this I noticed you said its the only game calling from the harddrive meaning you're most likely running multiple harddrives, the game being seperate from the harddrive your OS is installed on. So you can pretty much skip the fresh install idea. First of all I would un-install the game from the second harddrive, and install it on the same one your OS is running off and see if that speeds things up. If it does, it means there's an issue with your second harddrive, hopefully only a connection. Disconnect the second harddrive like I said earlier and reconnect it. Also make sure nothing is tangled up or folded like a water hose. If this doesn't help you, you may need to look into getting a new harddrive.
 


Last edited:

ruggb

Honorable Member
#4
don't know if u solved this, but if not, it might have something to do with the OPTIONS
If u set the GAMES to show as a menu then open it, there is an options tab.
Under that the defaults for GAMES FOLDER OPTIONS may need to be unchecked.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.