Ghost folder - unusable?


Extraordinary Member
Mar 26, 2010
I did a file restore from a backup program (Retrospect), but I cannot seem to be able to do anything with the folder it created, even delete it.

The folder icon is grayed out..?

I do have permissions on it, and am the owner, and also have admin privileges.

Opening a cmd prompt as admin, and going to the Desktop directory, a dir does not even show the folder.

Trying to open it:








  • p3.png
    6.4 KB · Views: 0
It's possible that the folder you restored from the backup is marked as a system folder or has certain permissions set that are preventing you from deleting it. Here are a few troubleshooting steps you can try:

1. Take ownership of the folder: Right-click on the folder and select "Properties." Go to the "Security" tab, click on "Advanced," and then click on the "Change" button next to the owner's name. Enter your username and click "Check Names." Once your username is recognized, click "OK" and then "Apply" to take ownership of the folder. After taking ownership, try deleting the folder.

2. Check folder permissions: From the "Security" tab in the folder's properties, click on the "Edit" button. Ensure that your user account or the "Administrators" group has full control permissions for the folder. If not, click on "Add," type in your username or "Administrators," and click "Check Names." Once recognized, click "OK" and then check the box for "Full Control." Click "Apply" and then attempt to delete the folder.

3. Use Command Prompt: If the above methods don't work, you can try deleting the folder using Command Prompt. Open Command Prompt as an administrator and navigate to the location of the folder. Type in "rmdir /s /q foldername" without quotes, replacing "foldername" with the actual name of the folder you want to delete. Press Enter to execute the command and see if it successfully deletes the folder.

If none of these methods work, it's possible that there is an issue with the backup or the Restrospect program itself. You may need to reach out to the software's support team for further assistance or consider alternative methods of deleting the folder.
1) as above, I am already the owner.

2) As shown in the post - both my account and administrator have full-control

3) C:\Users\guthrie\Desktop>rmdir /s /q Recovery
Access is denied.

The backup program is not running, it did a restore which created this folder.

It look likes you are running Onedrive and I think Onedrive generated those messages.
Many times Onedrive interferes with what I wants, because it is synchronisation tool.
I don't have a direct answer.
Try opening Onedrive and expiriment.

I have disconnected OneDrive from its default initial setup where Desktop & others are actually on the cloud (ugh!).

This folder does not show up in OneDrive.
Your first picture shows Onedrive. IMHO it is stil interfering somewhere. Maybe restoring the initialen set up, giving onedrive what it wants. Or opening Onedrive?
Again I have no direct answer.
Somebody else?
Thanks - but I don't see OneDrive anywhere in the posted pictures?
They all show C:/users/guthrie/Desktop/Recovery
Can you clarify for me please.

What's interesting (?!) is that it shows up in the GUI desktop, but not anywhere else - not in a cmd prompt dir, not in an explorer file listing.
PS: I like the idea to move it back to its initial (created) location, and see if anyone gets more happy - but I cannot move it - same problem, permission denied.
Ah, yes, thanks.

That is because W11 on install had moved several folders to OneDrive, instead of actually under /users/... - I moved them all back, and removed the sync on them - that predated this issue by a week or so.

This restore data folder was actually put at C:/Recovery, but I didn't want it there, so moved to C:/users/.../Desktop, and from then it was broken.
Well, it is not in C: anymore, and in Desktop it is not found or untouchable - Argh!!

C:\Windows\System32>rmdir c:Recovery​
The directory is not empty.​
C:\Windows\System32>rmdir /s c:Recovery​
c:Recovery, Are you sure (Y/N)? y​
The system cannot find the file specified.​
C:\Windows\System32>cd c:/users/guthrie/desktop​
c:\Users\guthrie\Desktop>rmdir /s Recovery​
Recovery, Are you sure (Y/N)? y​
Access is denied.​
c:\Users\guthrie\Desktop>dir Recovery​
Volume in drive C is System​
Volume Serial Number is 2C5A-3597​
Directory of c:\Users\guthrie\Desktop\Recovery​
File Not Found​
C:\Windows\System32>rmdir c:Recovery
The directory is not empty.

- You working directory is C:\Windows\System32>, and you try to remove the file 'Recovery' from there?
- If you expect it to be located in the toplevel of drive C: you should
- either change the working directory first with: 'cd C:\'
- or use rmdir 'C:\Recovery'

C:\Windows\System32>rmdir /s c:Recovery
c:Recovery, Are are in sure (Y/N)? y
The system cannot find the file specified.
C:\Windows\System32>cd c:/users/guthrie/desktop
c:\Users\guthrie\Desktop>rmdir /s Recovery
Recovery, Are you sure (Y/N)? y
Access is denied.

- Onedrive tries to keep the desktop synchonized?
c:\Users\guthrie\Desktop>dir Recovery
Volume in drive C is System
In the Desktop is a only link to C:\Recovery

Volume Serial Number is 2C5A-3597
Directory of c:\Users\guthrie\Desktop\Recovery
File Not Found

- There is a link, but maybe only on Onedrive? Who knows

- That is what I can make of it.
Please use '\' (backslash) in directyory specification,
Either change you working directory or use full specs with the whole path
Again not very helpfull, sorry
Thanks - I have tried all of those!

But, I did try this, and for the first time I do see it:

C:\Users\guthrie\Desktop>dir /adh​
Volume in drive C is System​
Volume Serial Number is 2C5A-3597​
Directory of C:\Users\guthrie\Desktop​
09/26/2023 06:53 PM <DIR> Recovery​
11/19/2023 05:28 PM <DIR> _gsdata_​
0 File(s) 0 bytes​
2 Dir(s) 588,241,571,840 bytes free​

But still,
C:\Users\guthrie\Desktop>rmdir Recovery​
Access is denied.​
Opening explorer in admin mode, I do see the folder.

Opening it there in properties;


But it won’t let me change properties from hidden and read-only – even though it shows that I own it, and am admin.

But this is something new,

Trying to delete it from this admin-explorer, I get this:

Not sure what it means, but it is new…

Online videos show how to try to remedy this… (will try it…)
The number of bites free in dir C:\Users\guthrie\Desktop tells me that it is located on Onedrive, and you can't delete it.
I am out off options.... 🤔
Last edited:
PS: The properties image - shows the folder itself is 0 bytes. But also note that it does not show up in OneDrive - so it seems to just be an artifact?!
yes a lot of Windows users mistake themselves as the owner of data and yes anything in onedrive belongs to Microsoft... yes even if they put it there without asking you
Top Bottom