Google Chrome won't word in Windows 7?

Discussion in 'Windows 7 Help and Support' started by MikeHawthorne, Jul 10, 2012.

  1. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    May 25, 2009
    Likes Received:

    The title is supposed to say Run in Windows 7?
    It won't let you edit the title, I don't know where Word came from?

    I've been using windows 8 for a long time, but today I booted back into Windows 7.

    After a lot of updates, video drivers, security etc, I opened my normal browser Google Chrome.

    It wouldn't load any pages, just a blank light blue page.
    Every link comes up with Untitled in the tab.

    I ran Malwarebytes, and MSE both updated.

    I opened Internet Explorer which I never use and it worked, but came up to a Blekko Search Bar page which I had never seen before and I had a hard time getting past it.

    I used Revo to remove the Blekko thing and an associated program.

    Chrome still won't work, I uninstalled Chrome and downloaded and reinstalled it.

    Still loads only blank pages.

    I think the Blekko thing may have caused the problem but it's gone and still no Chrome.

    All of my malware scans come up clean.

    I can't get into tools in Chrome because that comes up blank too.

    My connection is fine, e-mail, and IE both work.

    Anyone have any idea?

    Chrome still works fine in Windows 8 that's where I am now.

    #1 MikeHawthorne, Jul 10, 2012
    Last edited: Jul 10, 2012
  2. razlef

    razlef New Member

    Oct 20, 2012
    Likes Received:
    This is what worked for me!topic/chrome/dr9yXGwU1Kc

    Basically, one has to rename chrome.exe to chrom.exe and then update manually all shortcuts. I was very close to return to Firefox, Google tech team should have a look at this since it seems to be a common issue under W7.

    Hope it helps you.

    Best regards, Razvan
    Bucharest, Romania

Share This Page