Group policy denying changes to McAfee

I've got a comp that used to be connected to a domain where it was locked down pretty tightly. I've got full admin rights on it, but it's still denying me the right to change settings in McAfee (and other programs like Windows Firewall, etc).

I *thought* I cleared out all group policies on the computer, but apparently not.

Right now McAfee is the last thing I have to try to get a program working (I think it's stopping it from running), but I can't find any way to shut it down, prevent it from working, or enable specific programs, every single setting is grayed out.

So, short of going into safe mode and deleting every McAfee file I can find, do you have any idea how I can completely wipe out all old security settings on this machine, group policies, etc?

Thanks in advance, hopefully I can stop pulling my hair out.

Thanks. I actually just found out it is (well, was) McAfee enterprise. I couldn't touch it with the uninstall without the password, not happy. Turns out I went in one by one to all the .exe's and changed the owner from "system" to "administrator". Rebooted a few times here and there into safe mode to delete files, and finally, it's gone.

Now, the group policies are still there, denying me making any changes to windows firewall, etc. Any ideas?


Honorable Member
Please explain. When you go to Windows firewall, can you make changes? If not, why not? Are the options greyed out?

Yeah everything's greyed out. Specifically if I want to go in to "turn windows firewall on or off", everything in there is grayed out, and it says "some settings are managed by your system administrator"


Honorable Member
Thanks. I actually had the ability to go in and allow specific programs, so that was ok. The #3 you wrote, that was a good idea, I tried it, deleted them and rebooted, and apparently there's still GPO's in there somewhere because those registry keys reappeared when I rebooted :(


Honorable Member
First, try to reset Windows group policy to default:
Local Group Policy - Reset to Default - Windows 7 Forums

Some other things people wrote:

1. I found by having Windows Live OneCare installed it grayed out my default firewall settings.

2. If you are running Zone Alarm
Open ZoneAlarm, select Firewall from the left-hand menu. Main Tab then click Advanced.
Make sure Disable Windows Firewall is ticked before clicking OK.

Resetting local group policy cleared up the windows firewall problem, rebooted and it stayed fixed, so let's see if there's any other gems left hidden in here at some point, we'll see. Thanks.


Honorable Member
You are welcome.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.