Hard Drive doesn't show up during install

Discussion in 'Windows 7 Installation' started by aceman118, Mar 20, 2009.

  1. aceman118

    aceman118 New Member

    Mar 20, 2009
    Likes Received:
    I am having a very strange issue during the install. I recently got some new components. My old computer included 2 80GB drives in RAID-0 (SATA) for the OS and a 320GB for files. I decided to just split the two 80GB drives between two computers for the OS and put the 320GB in one for files and a new 1TB drive in another. When I first booted the computers everything seemed fine. The drives show up in the BIOS in each computer fine. I get to the "Where would you like to install windows?" screen but the only drive that shows up is the 1TB. After trying everything I can with the BIOS - IDE mode, AHCI mode, RAID mode, etc - I decided to just install windows to the 1TB drive to see if the drive is just messed up. So I get into windows and right away a pop-up says I need to reformat the drive. OK, so I do a quick reformat and the drive shows up perfectly fine in windows now. I restart back into the install disk but the drive still doesn't show up. I go back to windows and do a full reformat and set the drive to active (not really sure what that does?) and no change.

    So basically I have 2 ex-RAID-0 drives that do not show up in the windows install at all now. They show up fine from the BIOS and within windows. Any ideas?

    EDIT: I would also like to add that I went to the RAID menu and did the whole "un-RAID" thing to separate the drives.
    #1 aceman118, Mar 20, 2009
    Last edited: Mar 20, 2009
  2. cmn

    cmn New Member

    Mar 17, 2009
    Likes Received:
    Your description of the problem has omitted a few important and relevant information i.e . what OS you have in the 80GB SATA drive ( SATA I or II?) in the old PC (s?) and are you trying to make an Upgrade Installation or Custom (Clean ) Installation of the Windows 7 Beta either in the originally planned 80GB or the Changed 320 GB HDD ( SATA II Right?)
    If you don't have VISTA SP 1 as the original OS , you cannot upgrade to Win7 and hence the importance of knowing your OS. If you have to make clean install , you need to get the SATA driver Floppy for Win7 setup to recognize the drive and then need to Format [partition if you don't want to waste all 320GB or 1TB hard disk real estate on this Beta OS.] using NTFS if the disk was previously using any other file system.
    My guess is you needed to insert the SATA driver disk from the Motherboard software CD if your SATA connectors are on the MoBo or the SATA driver disk of the SATA add- On card if the SATA HDD is connected to a PCI or PCIEx slot at the drive detection screen during the setup. That way the Setup will know the existence of the drive and access it to Partition/format and copy the installation files. If you have already considered and tried all these , then give us more details for someone to help you with different tips.
  3. baldwinr99

    baldwinr99 New Member

    Mar 22, 2009
    Likes Received:
    possible fix for your RAID 0 drive issue

    I had pretty close to the same problem. Try this

    Connect both drives and turn on RAID in bios. Enter RAID utility and look at the drives. If you still have drives configured as RAID 0 delete them. Now recreate them both in RAID 0. Next reboot machine into BIOS and change from RAID to SATA. Boot to your windows 7 DVD and you should now see at least one drive that you can install too. Once install is complete, figure out which drive actually installed the OS and disconnect the drive (or leave in if you want a second drive).

    I do not know why the drives fail to show up. It is a low level issue I presume. You would think that deleting the RAID 0 in the RAID utility would be the correct way to resolve this but it did not for me. I had to leave the fresh configured RAID 0 configured, switch from RAID to SATA in BIOS and then I could see the drive. Let me know if this worked for you


Share This Page