Having an issue with Windows recgonizing an External Drive. Can't access the files

Discussion in 'Windows 7 Help and Support' started by WilliamPerdigon, Jan 14, 2012.

  1. WilliamPerdigon

    WilliamPerdigon New Member

    Joined:
    Jan 14, 2012
    Messages:
    4
    Likes Received:
    0
    Hello and thank you for taking the time to read my post. I hope someone here can point me in the right direction.
    I am using Windows 7 64 Bit. I have a Thermaltake BlacX eSata USB Docking Station. I will from time to time put a 250GB Seagate drive in this and use it to back up photos and random documents. I don't do it often, maybe once every 4-6 months usually with a fresh install coming afterwards of Windows.
    Today I plugged in the docking station in the computer. These are the steps I took to try and access the drive. 1)Right clicked "start" 2) Opened windows explorer 3)The drive is no where to be found under "computer"
    My next step was 1)Right Clicked "My computer" on my desktop, 2)Clicked on "manage", 3)Selected "storage" then "Disk Management".
    The drive appears here under "Drive 1" and it says "disk 1 Basic 232.88 GB Online" The bar above the drive is Black indicating it's "unallocated" and there is no Letter Assigned to the drive. In the past, I have assigned this drive as "Q".
    I right click into the section of the drive and I get "New simple volume" "properties" and "help" as options.
    Confused, I opened up a program called Easeus and I see that "Q" is there under the import feature, but when I try to import it I get an error/warning: "Q is not accessible, access is denied"
    I would really not like to have to reform that drive. I have important information on it that I would like to keep including a lot of Family pictures that we don't have anywhere else. Can someone please help me out with how I can access this drive or what steps I need to take in order to open this drive? Keep in mind, I have also tried all the basic steps of plugging the hub into every USB on my pc, ejecting the drive and plugging it back int, restarting the pc, turning the hub itself on and off. Nothing is allowing the drive to be accessed.

    Thank you very much for your advice.
    William Perdigon
     
  2. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    DId not see that you tried a reboot witht he drive connected. I have western digital esata/usb, sometimes it will only be detected after a reboot. I know you can see yours but worth a try if you have not already done so.
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You seem to be saying you have used the drive before in this configuration.. Have you used it with any other computer?

    While in disk management, if you look at the left end of the bar are there any symbols, possibly red?

    Does the drive or Docking Station show in Device Management without a yellow symbol?

    Do you have another drive you could try to test the docking station?

    As helpifIcan mentions, in some cases the drive may need a reboot (which you did), but I was usually able to do a scan in Device Management to have an external USB drive recognized.
     
  4. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    Besides using with another PC did you use with another version of Windows or Linux?
    Joe
     

Share This Page

Loading...