Having Connection Problems? Possible Solution.

Discussion in 'Windows 7 Help and Support' started by MikeHawthorne, Jun 25, 2011.

  1. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi everyone!

    I have been having problems with my internet connection for the last few weeks.

    I had to constantly restart it by going into network connections and disabling and re-enabling it.

    I always had this when Bonior Services was installed, but I looked and it didn’t show up as installed.

    It was driving me buggy.

    Well tonight I was looking through running services and there is was “Bonjour Services”!
    Only I can’t just uninstall it because it doesn’t show up as installed.

    I ran a search, and this is what I found, on another forum, by “Raine”
    The only error in this post was the path to the Bonjour folder in Windows 7 which I have corrected.

    I ran through this whole process and so far I haven’t had any connection problems.

    After 2 years wouldn’t you think that someone would have solved this conflict?
    It makes me wonder if this isn’t Apples way of sabotaging Windows 7.


    So if you are having problems staying connected and I have seen a number of posts lately from people who have, check this out…

    Mike

    --------------------------------------------------------------------------------------------------------------------

    1. Identify if Bonjour is installed:

    From the Start menu, select Control Panel, and then type services. Click on the View local services link in the Administrative Tools group.

    If the first line in the list of services looks similar to (I just looked for Bonjour Services and there is was)

    ##Id_String2.6844F930_1628_4223_B5CC_5BB94B879762##, you have Bonjour on your system.
    You may now close the Services window.

    2. Open a command prompt with Administrative privileges:

    3. Execute the following commands:

    cd \Program Files (x86)\Bonjour
    mDNSResponder.exe -remove
    ren mdnsNSP.dll mdnsNSP.old

    4. Finally...

    Close the command box and restart the computer, then delete the Bonjour folder from the C:\Program Files (x86) folder.

    Chow, Bonjour!

    Note from Adobe: Removing Bonjour prevents Version Cue clients (Photoshop, Illustrator, InDesign, Flash, Bridge) from automatically discovering Version Cue Servers and Version Cue projects in your local network. You will need to connect manually using Connect to Server and the URL or IP address of the machine running Version Cue Server instead
     
  2. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    It is a very old thread/topic on this site. Quickest solution is to just disable it in the services. If you do a search, you will find countless entries on the subject, dating back for some time. This will immediately stop the connectivity problems, But deleting it altogether is an excellent suggestion. I believe (not sure now) that it is also in the Startups in Msconfig. It should also be removed (unticked) from there.
     
    #2 davehc, Jun 25, 2011
    Last edited: Jun 25, 2011
  3. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    I know that I have dealt with this here and other places for a long time.
    In fact it was the first problem that I ran into when beta testing Windows 7.

    The difference was that it always showed up as an installed component in the Uninstall list before, at least on my computer.

    This is the first time that I wasn't aware that it had been re-installed or able to just delete it in the normal manner.

    Well, once again getting rid of it seems to have solved my connection problems.

    I hadn't been able to update the Apple software for a long time due to issues covered in another post but fixing that problem seems to have caused this one again.

    Mike
     

Share This Page

Loading...