Hd "disappears" after waking from sleep mode!!!

Status
Not open for further replies.

EDAL

New Member
#1
After my desktop wakes from sleep mode, one of my HD drives "disappears" and is no longer available nor is it seen listed under "My Computer". An additional one, not the one with the OS (of course), is there after the PC wakes.

I am running Win 7, 64 bit, installed on an ASUS M3N-HD/HDMI MB, with 8G RAM. The HD disk is a SATA, WD.

Is this happening to anyone else?

:confused:
 


Last edited:

reghakr

Essential Member
#2
Could you post a screen shot of disk management?
 


EDAL

New Member
#3
Yes of course, please tell where from should I get the screenshot, thanks for your very quick reply!
 


reghakr

Essential Member
#4
Go to Start,. Run,. and type diskmgmt.msc
 


EDAL

New Member
#5
It's Disk one, partitioned in two, the one that "disappears". I should tell you, after restarting it sits there allright, it just happensa after waking from sleep mode.

I do not have an URL so I've attached the screenshot, thanks again for your help!

 


reghakr

Essential Member
#6
Disappear where?

Under Windows Explorer or when you open Computer on the desktop?
 


EDAL

New Member
#7
Before you saw them now you don't!

I cannot see the disk anywhere!

(I quickly put the machine into sleep mode and back, and see the screenshots)
 


reghakr

Essential Member
#8
Sorry,. I don't understand that one.

Try going to Power Options,. then click the Choose when the computer sleeps,. then click the Change advanced Power setting and look over the options.
 


EDAL

New Member
#9
Checked that out but the HD's are set to shut down after 20 minutes not immediately after going to sleep (and permanently for thet matter!).

Notwithstanding, thanks for trying!
 


reghakr

Essential Member
#10
Sorry I couldn't be of further help.
 


Digerati

Fantastic Member
Microsoft MVP
#11
This was a bug in Win7 Beta, but supposedly was fixed in the final release. Are you still using a beta?

You might try setting the HD power off setting to Never and see if that changes anything. The HD should still power off when the computer goes to sleep, but hopefully will spin up and be recognized when it wakes up.

Also, I recommend re-lettering your opticals. I always make mine Q: and V:. In this way, your letter assignments don't get shuffled about when something like this happens, or if you connect a memory card reader, or some other detachable drive.
 


#12
This was a bug in Win7 Beta, but supposedly was fixed in the final release. Are you still using a beta?

You might try setting the HD power off setting to Never and see if that changes anything. The HD should still power off when the computer goes to sleep, but hopefully will spin up and be recognized when it wakes up.

Also, I recommend re-lettering your opticals. I always make mine Q: and V:. In this way, your letter assignments don't get shuffled about when something like this happens, or if you connect a memory card reader, or some other detachable drive.
Changing the power options, to have the disk never go to sleep, apparently did the trick!

I put the machine to sleep and woke it up and the disk was still there. Hopefully that took care of that!

Much obliged for your help!

:eek:
 


#13
Oh! BTW, I am not using the Beta version, it's the Windows 7 Home Premium Family Pack.
 


Digerati

Fantastic Member
Microsoft MVP
#14
Changing the power options, to have the disk never go to sleep, apparently did the trick!

I put the machine to sleep and woke it up and the disk was still there. Hopefully that took care of that!

Much obliged for your help!
Great. Glad that worked. Thanks for the followup.

Oh! BTW, I am not using the Beta version, it's the Windows 7 Home Premium Family Pack.
Hmmm, then it would appear there's still a problem, at least for some folks. Thanks for that bit of information too.

I note ASUS has released a couple BIOS and Win7 64-bit chipset driver updates for that board, though they don't mention this sleep issue. I normally don't recommend updating BIOS or drivers except (1) it addresses a specific problem you are having, (2) it addresses a security issue, or (3) current one is corrupt. Since changing that setting seems to have resolved your problem, I would let it be for now - but keep it mind.
 


reghakr

Essential Member
#15
I';d open up the case and make sure are connections are securely seated
 


Digerati

Fantastic Member
Microsoft MVP
#16
I';d open up the case and make sure are connections are securely seated
Looks like changing the setting took care of the problem.
 


Status
Not open for further replies.
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.