HDD Under Device Manager but not Disk Management

#1
Hey guys, back again.

The problem is pretty straightforward, right from the title. I have a 750G HD that shows up under the Device Manager, but not under Disk Management. It's in the Bios. But not in the Win7 OS. Honestly, I'm a little confused.

What's worse, I uninstall it from the Device Manger, it reinstalls itself, and still wont show under Disk Management. Yes, all cables are installed correctly, I've tried multiple cables, different slots, and I've even tried shifting it around in the BIOS. And unfortunately, Googling "Missing Hard Drive under Windows 7" (or any other variant) leads to the same old topic of people missing their Vista or XP partition because it never assigned a drive letter. Huzzah. Does anyone else have this problem?
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#2
Hi Donavenn,
if you can see the drive in My computer try running a chkdsk. Also HDD manufacturers usually have some sort of diagnostic utility that will tell you if the drive is ok or not. Try running the utility on the drive.
If your unsure where to go, list your drive and I'll point you in the right direction...
 


#3
Ha! My friend, you are a good luck charm.

As I wrote up this problem I was running a deep scan using testdisk. When it finished scanning the partition, I rewrote it back to the disk and now it's like it never left. It's a beautiful thing, I tell ya.

6 years of backed up Television Shows, Movies, and Music. My entire collection is home again!

Thanks for the help anyway, my friend.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#4
Fantastic! All that material saved... Can I suggest that you burn some of it to disk? Anyhow, once again well done..:D
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.