Help! Can't get Loopback Adapter Working

Hello all,

First time post, have spent several days and nights trying to get this going, and no luck. A bit of a nube.

I am attempting to install a Virtual Machine (Server 2003) and connect to it from my host. I have installed the VM and it is up and running.

Here's what I've done so far... (have run the same steps with a WinXP host and it seems to work fine)

On the host machine (Win7 RC), installed MS Loopback Adapter
It comes up as "Unidentified Network" in the "Public" domain, no way I can find to change this to Private
In properties of the host adapter, disabled ipv6, set ipv4 IP address to static:
Set VM settings to use the loopback adapter as its network adapter
Start VM, change it's IP to
On host machine, edit hosts file to include "name"

Now, I should be able to ping the VM from the host and vice versa, but neither works.
The Loopback adapter shows as "no internet access" status

Any help is appreciated...

Tried disabling virus/firewall

By the way, I uninstalled AVG and disabled Windows Firewall, same results.

Success! Set the gateway of the loopback to the VM's IP

Wouldn't you know that I've been searching for several days, finally give up and ask for help here, and 1 hour later find the answer that worked for me.

I got it here:

Setting the Loopback Adapter Connection to Private in Windows Vista - Windows Live

A Windows Live blogger called Lambros called it. Thanks!

Short version: In your loopback adapter TCIP settings, set the gateway to the IP address of the virtual machine. This will cause the loopback to start searching and, after a disable/enable cycle, find the network. You will now be able to convert the network to "Private" which will allow you to connect to the VM from the host. Excellent.

I can't believe that the behavior of loopback connectors defaulting to Public with no ability to change them is the desired behavior. How can this be submitted as a bug to be fixed in the release?

Loopback broken again

OK, so this appears to just be me talking to myself, but the solution is no longer working. The Network and Sharing Center allowed the change of the Loopback connection from Public to Private after the initial change of it's gateway to point to the VM. However, after a month of working, it has now stopped. ENable/disable, uninstall/install now no longer gets prompted to make the change and I haven't found another solution.

I have seen numerous threads about Vista "forgetting" the classification of network connections, wondering if Win7 has this same issue.

Any ideas?

A thread ruled by the poster himself!!! juz kiddin m8.. BTW, I would like to help u, but unfortunately no clue on wat u r talkin abt..personally I hv nt tried the Virtual thing concept..sum1 els havin a knwledge wuld come to ur patient.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.