Help - I have lost access to my external hard drive

Discussion in 'Windows 7 Hardware' started by cygnus333, May 23, 2009.

  1. cygnus333

    cygnus333 New Member

    Joined:
    Jan 29, 2009
    Messages:
    58
    Likes Received:
    0
    I have brought my external hard drive from my home to my son's house. Once connected, I tried to view a folder in the root of the drive. I get the pop-up message "You don't currently have permission to access this folder. Click continue to permanently get access to this folder." After I click continue I get this message. "You have been denied permission to access this folder. To gain access to this folder you will need to use the security tab." When doing that I get the msg. "You do not have permission to view or edit this object's permission settings." From there clicking on advanced does not help. Does anyone know how I can get around this problem and access my drive just like it is connected to my home system?

    The drive is a Seagate FreeAgent external USB 1 TB. Both systems are running Windows 7 64-bit build 7100.

    Thanks in advance,
    Cygnus333 (Chris).
     
  2. woody43526

    woody43526 New Member

    Joined:
    Jan 25, 2009
    Messages:
    14
    Likes Received:
    0
    Ah that happened to me once lol
    on your computer at home you have keep my files private on yuor usr, which then transfers on to your external harddrive.
     
  3. cygnus333

    cygnus333 New Member

    Joined:
    Jan 29, 2009
    Messages:
    58
    Likes Received:
    0
    That explains how I got in this fix. Now, any suggestions on how I can access my files on the external drive. My home computer is 45 minutes away from here.
    Thanks, Chris.
     
  4. guren2

    guren2 New Member

    Joined:
    Mar 21, 2009
    Messages:
    16
    Likes Received:
    0
    do u have windows live mesh??
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello,

    There is a MS patch for that through Windows Update if you're running the 32-bit edition.

    You can also right-click on the drive letter, choose properties. On the Security tab what group is listed there.

    Everyone?

    You can also use this registry script to Take Ownership

    Copy and paste the info inside the quote into Notepad, choose Save As, then select All Files from the drop-down menu box and type in takeownership.reg. Save it to your desktop and double-click on it to merge it intro the registry. this will place Take Ownership of files and right-click context menu for complete directories.

    Please post back and let us know if that worked.
     
  6. cygnus333

    cygnus333 New Member

    Joined:
    Jan 29, 2009
    Messages:
    58
    Likes Received:
    0
    I was able to change the ownership under properties/security tab.

    Thanks for the help everyone.

    Chris
     
  7. Eric-Tech

    Eric-Tech New Member

    Joined:
    Nov 10, 2009
    Messages:
    6
    Likes Received:
    0
    I'm also having trouble accessing files from my hard drive. The hard drive I have is hooked up via a usb cable, the Windows XP on it is borked (keeps coming up with a BSOD, I already cleaned it from viruses) and I have no repair option to do a XP repair on it.. so I'm trying to recover the pictures in My Documents (C:\documents and settings\user\my documents) but it keeps coming up with the cursed "You don't have permissions.." errors, even after running that reg entry in my Windows 7 Home machine.

    Help me, Obi Wan! Before I throw this thing out the window! :D:eek:
     
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Have you tried all the suggestions above?

    Can you just select the Documents and settings folder and choose Copy, then paste to a flash drive.

    You'll get a couple error but it's nothing to worry about.
     
  9. Eric-Tech

    Eric-Tech New Member

    Joined:
    Nov 10, 2009
    Messages:
    6
    Likes Received:
    0
    yes I tried the registry entry, I have tried the copying of the documents and settings folder.. the only thing it would copy was ntuser.dat.
     
  10. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Did you specifically select the top directory, the Documents and Settings folder itself?

    You could try Safe Mode.
     
  11. Eric-Tech

    Eric-Tech New Member

    Joined:
    Nov 10, 2009
    Messages:
    6
    Likes Received:
    0
    had to take it back to an XP machine, run subinacl and MS's reset permissions command... nasty virus!!!
     

Share This Page

Loading...