[HELP NEEDED] Some files are invisible over my networks....!

Discussion in 'Windows 7 Networking' started by denissianto, Feb 2, 2010.

  1. denissianto

    denissianto New Member

    Joined:
    Feb 2, 2010
    Messages:
    10
    Likes Received:
    0
    Hi,

    Could someone help me please,
    I am using two computers at home, both Windows 7. One is pc, Other is laptop.

    Problem is, some file that I downloaded off the net to my laptop, had a 'lock' symbol on its icons..
    [​IMG]

    And those files with a lock symbol on it, prevented my pc to 'see' those files over the network.

    My PC had no problem at all to see those shared folders, files, or applications in my laptop. EXCEPT the one with lock symbol.

    What's strange, using the same method, downloading the same files off the net using IDM through my PC, the downloaded files didn't have lock symbol on it.
    So this happens only at my laptop.

    The only way to remove those lock symbol is to right click at it, properties, security, edit, add, input 'everyone', and the lock symbol is gone!
    But this method costs me a lot of time to 'convert' each files to non-lock.

    Please help how to make all files downloaded to my laptop to become normal (no lock symbol)
     
  2. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
  3. denissianto

    denissianto New Member

    Joined:
    Feb 2, 2010
    Messages:
    10
    Likes Received:
    0
    I've checked it. It does not really answer my question though.

    I've now found the problem that prevents me to "see" this files on my laptop over network.
    It has something to do with the "share with" options when you right click an item. If you right click on that pad-locked item, and choose homegroup, then the file WOULD SHOW UP OVER NETWORK.

    However, this simple solution did not fully resolve my problem. As I wouldn't want to right click at my files each time I finished downloaded a few files off the net.
    Are there anyone who can help me solve this ?

    PS: I have tried to uninstall my antivirus and every downloaded files still have a padlock status on it.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It would seem that there may be some permission inheritance going on. Typically you want to create the sharing at the root of the share, let's say you have a folder on your hard drive called share. Then you right click on that and choose share with and then choose how you want to share it, if at that time you select "Nobody" then the files you download to that folder will in all likelyhood inherit the "Nobody" and will exhibit the lock symbol. You can start from scratch and see if I'm correct, or perhaps just, instead of clicking on each individual file to unlock (share with) it, try trying right clicking on the folder that the files are contained in and choose share with and then select the option you want and if you are prompted make sure you include subfolders and files. Let us know if this is any help
     
  5. denissianto

    denissianto New Member

    Joined:
    Feb 2, 2010
    Messages:
    10
    Likes Received:
    0
    Both of the methods didn't work out. In fact I have tried those before.
    Basically, if the root folder (folder where download files go) status were changed from "share with: homegroup - read/write" to "nobody", the folder will be padlocked, and it would disappear from network.

    And this changes, DID NOT affect files and subfolders inside it.

    Therefore changing the 'share with' status of the root folder would only change the visibility over network of the folder alone.
    The files inside it, which was padlocked still is padlocked.

    thanks for trying to help me though.... :)



    anyone else could help?
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    That's what I was affraid of, it seems you were unable to cascade the change in permissions on down to the contents of the folder, subfolders and files, otherwise there status would have changed also. Probably has something to do with homegroup sharing or simple file sharing or something. Did you try the creating a new shared folder method, create it on the C drive call it downloads and perhaps instead of using the simple file sharing method, use the advanced sharing button, and set permissions up as you want them also look under the security tab and make sure permissions are correct there, then download a file from the internet into that directory and see if it exhibits the padlock.
     
  7. denissianto

    denissianto New Member

    Joined:
    Feb 2, 2010
    Messages:
    10
    Likes Received:
    0
    I've found the culprit. It was my Internet Download Manager... IDM version 5.18 build 8

    With the same version and same settings, If I downloaded the files off the net (same file, same location), the files in my computer wouldn't be padlocked. only the files downloaded through IDM to my laptop would be padlocked.
    Files downloaded directly to my laptop via Mozilla firefox would be fine.

    I now see that the folder 'share with' setting did not have any effect on the downloaded files. The setting would only affect the visibility of the folder over network.


    Can you help me on this one ? what could it be?
     

Share This Page

Loading...