Help: Network Printer through Switch/Hub

Discussion in 'Windows 7 Networking' started by skimyy, May 22, 2012.

  1. skimyy

    skimyy New Member

    Joined:
    May 22, 2012
    Messages:
    8
    Likes Received:
    0
    Hey guys. I am working at a small office firm, and we just got a brand new printer.
    Specifically the Kyocera KM-6030.

    I've connected the network cables to the Switch/Hub and tried to connect it, but it does not appear on the network/printer list.

    I've tried to configure the TCP/IP settings, which the IP address of the printer is 192.168.9.89

    I know alot about computers and softwares, but I am a HUGE noob in networking (trying to improve my knowledge).

    What are the proper steps to connect computers via hub/switch to a network-capable printer?


    I've already tried making new printer "ports" where I manually entered the printer's IP address, but the install wizard keeps saying the device is not on the network.

    Any help would really be appreciated.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum.
    If you have created a new TCP/IP port named 192.168.9.89 on your computer then you don't really use an install wizard.
    You add a new printer, local printer, select the port (the one you created above) and install the driver.
    You should probably make sure that you can at least ping the printer with the IP address and perhaps open a browser and type http://192.168.9.89 into the URL/Address bar (not search bar) and see if you can see the printer's web interface.
    This all assumes that you have set a static value of 192.168.9.89 for the printer and configured the subnet mask (255.255.255.0) and the gateway on the printer using the front panel LCD or by some other means, and that address is not conflicting with another network node and is excluded or reserved within the networks DHCP scope.
    Regards
    Randy
     
  3. skimyy

    skimyy New Member

    Joined:
    May 22, 2012
    Messages:
    8
    Likes Received:
    0
    I thank you for the response.

    The printer has been added, and i've tried to print a test page, but it fails.

    It seems I can't ping to the printer at all either.

    The current network setttings for the printer is as shows:

    IP Add: 192.168.9.89
    Subnet Mask: 255.255.55.0
    Default Gateway: 192.168.9.7
    DHCP: OFF
    BOOTP: OFF

    When I go through the add printer option, I select ADD LOCAL PRINTER, CREATE NEW PORT (using Standard TCP/IP Port), and then i input the IP Address of the printer (which is 192.168.9.89).
    Then I go through the driver installation, and the install completes, which results in the printer appearing in the Printers and Devices list.
    I am then given an option to send a test page, which fails.

    I am really stuck here.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Delete everythng in the print queue. Stop and restart the spooler service and try again.
    If still no joy, go into printer properties, select the ports tab, hightlight the TCP/IP port and click configure
    Switch it from raw to LPR, give it a QUEUE name of PORT1, OK your way back out of there and clear the queue and restart the spooler and try again.
    Check the documentation for how to get into the printer's web interface, I'm suprised you can't ping it but it may be off by default.
    I assume that you are sure every node is on the .9 subnet?
    Some of those printers can be tempermental you may have to configure the work group name or if present a domain name and point it at your DNS server if you have one.
    I've set up a few Ricoh, Xerox and Savin printers and sometimes they seem to want an LPR port so I hope that works.
     
  5. skimyy

    skimyy New Member

    Joined:
    May 22, 2012
    Messages:
    8
    Likes Received:
    0
    Thanks for the reply.

    After fiddling with it, I turned on DHCP and BOOTP.

    After turning those on and a hard restart of the printer, the Printer got itself a new IP Address. (it changed to 192.168.1.176)

    I then used that IP address and repeated the standard steps of connecting to the printer.. and it works!

    Now, I have NO idea what in the world the DHCP and BOOTP does. (I've googled the definitions of it, and really haven't absorbed any kind of understanding)

    I have a feeling that this may have a long term penalty (maybe future disconnects, etc), which is really bad because I just went through connecting about 10 computers to this Printer...

    Should I be worried? or has the installation been a success?
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    The problem was, evidently, at least according to the information you have supplied, your original IP addressing of the printer was never on the same subnet as the rest of the network nodes.
    You had it set on the .9 subnet (192.168.9.89 with a 255.255.255.0 class C subnet mask, assuming that the .55 you typed above in the third octet of the subnet mask was a typo since there is no actual .55 possible).
    If it works now on the .1 subnet with a 192.168.1.176 address by virtue of DHCP that would mean that, that is where the rest of the nodes on your network are also.
    Now as far as long term issues. Those are only likely to come in the event of IP reassignment that might result from a power outage or someone or something completely resetting your DHCP server and or its' associate DHCP Scope.
    Since you haven't really said what is providing DHCP on your network (router or and actual DHCP Server) there are a couple ways to protect against that happening.
    First you would need to statically assign that value (192.168.1.176) within the printer's web interface->network configuration and then you would need to either reserve or exclude that number from ever being handed out by whatever is actually providing DHCP on your network. Reservations are usually the easiest but it will depend on your DHCP server's interface and what you are able to do. You can exclude it by making sure that your DHCP server hands out only numbers above that (192.168.1.177 to 192.168.1.254) or only numbers below that 192.168.1.2 to 192.168.1.175) making sure that the DHCP server address as well as any other IP address that need to be fixed or static are also outside both or either scope.
     
  7. skimyy

    skimyy New Member

    Joined:
    May 22, 2012
    Messages:
    8
    Likes Received:
    0
    Thanks for the reply again.

    I will definitely look into the DHCP Server configs, etc, and try to dig up some more solid info.

    Also, you are a genius.
     

Share This Page

Loading...