Help with drivers?

#1
I really don't know what to say, I don't know what's happening to my computer lately.
My computers been acting really slow for the past maybe 4 days. It's hard to open any of my files without waiting too long, and my internet browsers are incredibly slow. It's not normal.
I thought it would be my CPU because that's been a problem before, but it's never above 15% or so, so I don't think that could be the problem.
I also have a driver problem I think? I have a screenshot to show you...
helphelp.png

See there's a yellow "!" mark beside my CD ROM drive, I don't know what's wrong with it. I've tried to update it, but nothing happens. I was hoping someone here could have some suggestions for me on what to do.
 


whs

Extraordinary Member
#2
For the driver problem, I suggest you uninstall the driver (in Device Manager > device properties) and reboot. The system should find a suitable driver automatically.

As far as the system slowdown goes, you have to supply more details. Have a look in the Reliability Monitor (type that into start/search and hit Enter) and tell us what is hidden behind the red circles. Look for the critical ones and click on the circles and then click on 'View Solution' underneath "Action".

PS: I just saw that the forum automatically inserted links with the word " Driver ". Do not click on those links. that is a hoax.
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.