Help with .NET framework problem & to be burned to CD/DVD problem

#1
I recently used a special tool designed to fully remove all traces of .NET framework from a Windows 7 install. I did this because I believed the files to be corrupted. I then tried to reinstall 2.0 because I need it for a program to work properly. Only I can't reinstall because the operating system still says I have .NET framework installed, even though this removal tool supposedly removes all traces registry entries & files. And it said it uninstalled everything fine. So what do I do now?

exact error message: This product is already a part of the operating system
additional note: disabled .NET framework before the uninstall tool ran

On a side note, a matter of less importance. I have a file that has somehow been added to a to be burned to CD/DVD system with Windows 7 that keeps showing up along with the files on any CD or DVD I put in my burner. And I can't get it to go away. If I delete it, it just comes back. How do I tell Windows 7 to screw off because I don't want any files to be placed in a to be burned to CD or DVD state?

Thanks in advance for any help anyone might be able to provide! :)
 


reghakr

Essential Member
#2
Hello ans welcome to the windows7forums,.

What tool dud you use to remove the .NET framework?

Is this the link you used:to try to re-install:
http://www.microsoft.com/downloads/...cb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en

Take a look here and see if v2.0.50727 branch exists.

I'm not advocating that you delete that branch, messing around in this part of the registry is dangerous.
 


reghakr

Essential Member
#3
Hi Drew,.

does he really need version 1.1?

I've never heard of the 3.5 Family Update,. is that available through Windows Update?
 


Last edited:
#4
The tool seems from the EULA to be a piece of Microsoft Unreleased Software, and is called .NET Framework Setup Cleanup Utility. It has an option to supposedly remove all versions of .NET Framework from a drop down list. I will try as you have suggested. Hope it works! :) Thanks!
 


reghakr

Essential Member
#5
I have a registry search tool and came up with 360 instances of .net on my Windows 7 Pro machine

Hope the tool works.
 


#6
"http://www.microsoft.com/downloads/details.aspx?FamilyID=aae7fc63-d405-4e13-909f-e85aa9e66146&DisplayLang=en"

This link mentions removing a bunch of things that are not on my list of things you can turn off, or uninstall, from windows components and installed programs in Windows 7.

The only one I have isn't listed, and you can only turn it off, is Microsoft .NET framework 3.5.1.

"2. In the Windows folder find folder named Assembly, Rename to Assembly.old & delete .NET folder from the Registry."

I located and renamed the Assembly folder. But how do I delete the .NET folder, and where is it?

"3. Next install all .NET items: 1.1, then, using MS Updates, .NET 3.5 SP1 & 3.5 Family Update should cover all the rest, then, still via MS Updates, all .NET SPs & Updates."

So I download and install 1.1, then use updates to install the rest?

More info on the file Windows wants to burn to DVD/CD

"Files Ready To Be Written To The Disc (1)"

desktop.ini

shows up everytime below list of files on DVD or CD in burner

no idea how to get rid of it...


 


Last edited:

reghakr

Essential Member
#7
I think this is getting a little over complicated.

Is the program that requires .NET 2.0 installed?

Do you get an error message about .NET when you tried starting thee program?
 


#8
"(Program Name Here) Has Stopped Working"

Windows can check online for a solution to the problem.

->Check online for a solution and close program
->Close the program

That's what I get when I run the program that needs .NET

I double click, then that pops up.

I may just do a repair. Hopefully I won't lose anything I have downloaded or installed other than drivers.
 


Last edited:

reghakr

Essential Member
#9
But how do you know it needs .NET when there isn't even an error message sating you need It?

No offense,. but why are you so secretive about the program name,. If we knew that,. it would be much easier for us to diagnose.
 


reghakr

Essential Member
#10
Drew,. did you look over posts # 9 and 10?

Does this make any sense to you?
 


#11
It's states on the download pages that you need it to have .NET for several of my programs work. Have several progs that need it. They all give the same message. Hence the "program name here", not a specific prog. They worked fine before. Then they mysteriously quit working all of a sudden. One of them doesn't even need to be installed, just runs from a .exe file. I redownloaded it. Tried to run it, same thing as the one already on the hard drive. Hence my conclusion that since it worked fine before the .NET files must be corrupt. Since both the new and the old one don't work any longer. And all progs that don't require .NET still work fine...
 


reghakr

Essential Member
#12
In my experiences with downloading software,. if it states it needs .NERT framework there should at least be a link for it on the download page.

How about giving us just one name of one of the programs,.

No disrespect,. but you're wasting our time when wee could find an east=y solution just by naming program.

If f you can't do that,. I can no longer assist you
 


reghakr

Essential Member
#13
lol,. tail between legs and ran:D
 


#14
That's funny reghakr. But no, I was too busy reinstalling Windows 7 & all my appz to reply. Then I went to bed, as it was oh 2:00 AM here. Thanks to everyone for your replies and your time. Unfortunately I could not figure out how to fix this problem without reinstalling, so that's what I did. All my progs that require .NET now work fine again. :) It's too bad that Microsoft has ALWAYS made it so hard to uninstall/reinstall things like IE, Messenger, .NET, etc... that are considered system components as opposed to installed programs. If I could have simply uninstalled .NET and reinstalled it I believe it could have saved a lot of time. In Windows 7 there is no easy or conveinant way to uninstall/reinstall things like .NET, it's a shame too....
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top