hiberfil.sys returns after reboot

Discussion in 'Windows 7 Help and Support' started by jmt, Feb 12, 2010.

  1. jmt

    jmt New Member

    Joined:
    Feb 12, 2010
    Messages:
    8
    Likes Received:
    0
    I'm running Win7 Pro x64. I have an SSD and 10GB RAM. I don't like having hiberfil.sys burn so much space and never use hibernation.
    Disabling all hibernation features via Control Panel doesn't get rid of the file, or allow me to delete it.
    Running "powercfg -h off" from an elevated prompt kills the file immediately. However, it comes back after every reboot.

    I've found nothing that addresses this ... thoughts?
     
  2. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Hello, and welcome to the Windows 7 Forums. :)

    Have you tried disabling it through Command Prompt and then also disabling it in the Control Panel?
     
  3. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Disk Clean Up

    Welcome to the forums, jmt.

    ~~~~~~~~~~~~~~~~~~~~~~~~~
    Also:

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Power

    HibernateEnabled => 0


    ~~~~~~~~~~~~~~~~~~~~~~~~~

    After you turn it off, follow these steps:

    Start > Computer > Right Click On system C > Disk Clean Up > More Options > System Restore and Shadow Copies > Clean Up

    [​IMG]

    Disk Cleanup - Open and Use - Windows 7 Forums

    Also, make sure the hybrid sleep option is off.




    ~~~~~~~~~~~~~~~~~~~~~~~~~~



    1. At the command prompt, type powercfg.exe /hibernate off

    2. Start menu > type Power options

    3. In the left pane, open the link labeled Change when the computer sleeps and then open the link Change advanced power settings.

    4. Under the Advanced Sleep options, expand the Sleep tree and turn off Hybrid Sleep.

    [​IMG]


    How to disable and re-enable hibernation on a computer that is running Windows

    How To: Enable Or Disable Hibernate Option In Windows 7

    Windows 7 – Enable or disable hibernation
     
  4. jmt

    jmt New Member

    Joined:
    Feb 12, 2010
    Messages:
    8
    Likes Received:
    0
    Cursed hiberfil.sys

    Good suggestions, but no go. I've turned it off via power options ... and here it remains listed as "off".
    I've also already done the registry and the command prompt.
    If I do the command prompt first, the registry is appropriately changed to '0' for that key, which I've verified.
    I've also tried doing the registry change first.
    In all cases, after a reboot, the registry entry is again '1' (though again in Power Options is shows as off/never) and hiberfil.sys is back.
    I also did the clean for kicks ... no joy.

    Very frustrating.
     
  5. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Did you also follow cybercore's suggestion of disabling Hybrid sleep mode?
     
  6. jmt

    jmt New Member

    Joined:
    Feb 12, 2010
    Messages:
    8
    Likes Received:
    0
    Yes ... I've done everything suggested. All but the registry before I posted. I've done them each again since. Still comes back each & every boot.
     
  7. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Turn hibernation on. Then Control Panel > Power Options > Advanced > Expand both Sleep and Hibernate, set all the settings to Off/Never/0 minutes.

    Now turn it off.

    After you have turned hibernation off, reboot. Then use disk C cleanup (see post #3), or delete it manually. Take ownership of hiberfil.sys. (You are supposed to have admin rights which I'm sure you do). Then manually delete it.


    If hiberfil.sys still reappears, then it should be significantly smaller.
     
  8. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Are you the sole user, or is there another, or user with higher status?
     
  9. jmt

    jmt New Member

    Joined:
    Feb 12, 2010
    Messages:
    8
    Likes Received:
    0
    Cybercore: I've done this, no go. Getting rid of the file is cake. Command prompt does it every time. The issue is it coming back every time. I have set the size to be 50% of RAM, which interestingly is a setting it does keep. Still though, that 5GB file is back after any reboot. I've done all Control Panel settings, reg changes, disk cleanup, command prompt, etc several times. All suggested thus far listed have been attempted.

    RAK: I am the sole user.
     

Share This Page

Loading...