Homegroup sharing problem - can't see all libraries/folders between computers

Discussion in 'Windows 7 Networking' started by 006, Dec 2, 2009.

  1. 006

    006 New Member

    Joined:
    Nov 7, 2009
    Messages:
    10
    Likes Received:
    0
    I have 3 desktops with W7 and I successfully set up the homegroup with all three turned on and running. On each computer, I selected all the boxes to share all libraries. However, when I go to the Libraries window and look under Network, I see each computer, BUT, I am finding that only some of the libraries show up, not all. I shut down and restart the computers as I use them. Nothing changes on restarts. What's wrong and how do I fix it?
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    One additonal step you can try on each computer that you are sharing libraries from...Open the libraries folder and right click on the individual library you should get a fly out window when you choose "share with"... make sure that is set appropriately for your needs according to what you are trying to get accomplished. See attachment. Hope this helps.??
     
  3. jagman

    jagman New Member

    Joined:
    Apr 13, 2011
    Messages:
    4
    Likes Received:
    0
    I have the same problems: I had a HP desktop with Win 7 Home Ultimate and 3tb of USB attracted and purchased a new HP laptop, same OS.
    Set up Homegroup and everything was shared, could read/write. the the HP went belly up so HP gave me a new HP desktop, same OS.

    Hooked up the 3 USBs with 3tb to the desktop, and JOINED with the laptop.

    Then the problems, suspect it is the CREATOR OWNER Crap cause the data on the USB was created on the old HP, same OS but it seems to know it was different.
    What I want to happen is to add yet another PC with more "foreign created" disk but can not if can not get the 2 new HP to share.
    I would like to make EVERYTHING to SHARE with EVERYTHING since i am the only user. BUT, Microsoft seems to be bound and determine to NOT us share without ourselves. Don't think there is a way to SHUT down all these crappy permissions. Tired of trying to get something done and getting "ACCESS IS DENIED" or "the FUNNY one "YOU dont have the permissions" as I AM the only one using these PC or access to.

    ANYONE found a way around without going back to XP pro which NEVER gave me any problems. The problem then is it violates my warranty with HP.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    jagman;
    Hello and welcome to the forums.
    You're correct in assuming that the old shares (permissions) will not work with either of the new computers. The security identifiers that exist are unique to the previous environment and no longer exist presently. Ideally you should clean up any old SIDs that no longer function but it can be a little confusing so....
    The simplest way to work around this if you truly want to share everything with everyone is to recreate the shares and set the share permissions to full for everyone as well as the NTFS permissions (located under the security tab in the folder properties) to full for everyone for each folder that you are sharing. This is not considered optimal nor best practices from a security stand point but it seems to be what you want to do, so while I am not recommending it, it is an option that you can employ.
     

Share This Page

Loading...