How do I disable Windows XP IDE checks?

Cardinal System

Honorable Member
I am setting up a virtual machine to host a Windows XP environment with specific legacy software to replace a customer's broken Dell MTC2 desktop. I used Disk2vhd to generate a VHD from the customer's IDE hard disk and created the virtual machine with VirtualBox. The system begins to boot but then stops with the following BSOD error:

MLyjR.png


If I copy the C:\WINDOWS directory from a different Win XP installation to this same drive and boot from it, everything works with no issues. I suspect that somewhere in the C:\WINNT directory is there is a corrupt file or registry entry. I tried running the following commands in the recovery console, but the OS still fails to boot:
Code:
chkdsk /r
bootcfg /rebuild
fixboot

This tutorial mentions that "Windows memorizes which IDE/ATA controller it was installed on and fails to boot in case the controller changes." It says that the solution "is to perform several modifications to the Windows registry" to disable these checks, using a tool called `MergeIDE`. Unfortunately, this approach requires the original computer to be functional, which it is not. It also provides a link to an MS Docs page, but I cannot find anything that details how to disable this checks.

How can I resolve this issue?
 
Last edited:

Neemobeer

Cloud Security Engineer
Staff member
Make sure the hard drive controller within Virtual box is set to IDE. XP does not support SATA without a driver.
 

Cardinal System

Honorable Member
It's definitely a corrupt registry. I copied the registry files over from a fresh Windows XP installation (on the same disk) and the OS booted without an issue. However, a lot of the programs previously installed do not work without the original registry files.

7R2cU.png


In addition, a lot of the programs previously installed do not work without the original registry files. So this is not a real solution.
 
Last edited:
Top