How do I kill AutoPlay so it's truly dead?

Discussion in 'Windows 7 Help and Support' started by srleslie, Aug 7, 2011.

  1. srleslie

    srleslie New Member

    Joined:
    Jan 12, 2011
    Messages:
    14
    Likes Received:
    0
    Every time I touch my laptop in the wrong place the DVD drive opens. That's annoying. But not half as annoying as the fact that, when I close the drive, Windows Media Player interrupts whatever it's doing to start whatever disk in it. I have AutoPlay in Control Panel set for "Take no action" in every case, but it makes no difference. Control Panel/Default Programs/Set your default programs/Windows Media Player shows it has "all its defaults" and clicking on "Choose defaults for this program" yields a long list of checkboxes all filled in and totally resistant to any efforts to uncheck them.

    I'm the sort who puts a manual choke in every car he owns, and I hate AutoPlay. Can someone tell me how to make it go away? Or is there something else I need to do here?

    Windows 7 Home Premium x64 on a Celeron laptop.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The attachment comes form the Windows 7 Help and Support section and describes Autoplay and Autorun. There are some internet sites that describe turning off Autorun, but some do not include Windows 7 and the iniFileMapping work around is not suggested due to side effects.

    So, it appears the answer is you may not be able to turn Autorun off. Maybe someone else will have a different answer.

    Holding down the shift key when inserting the media might be an alternative, doing that may not even still work.
     

    Attached Files:

  3. srleslie

    srleslie New Member

    Joined:
    Jan 12, 2011
    Messages:
    14
    Likes Received:
    0
    Thanks. I suspected an important distinction between AutoPlay and AutoRun, and this verifies it. The fact that "Autorun is incorporated into the media types that use it..." would bolster the sad news that it may indeed be un-turn-off-able. Thanks a lot, once again, Microsoft.

    The shift key, alas, has no effect.
     
  4. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    2 people like this.
  5. srleslie

    srleslie New Member

    Joined:
    Jan 12, 2011
    Messages:
    14
    Likes Received:
    0
    Hmm, worth a try. But didn't work. Set Registry bit to 0 as specified, restarted computer, checked that change "stuck," Autorun still ran when DVD inserted into drive.
     
  6. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Damn! I hate it when that happens (i.e. nothing!!).

    Sorry but that is about my best shot!!
     

Share This Page

Loading...