How to delete or reset adapters

Discussion in 'Windows 7 Networking' started by DaveUK, Mar 8, 2010.

  1. DaveUK

    DaveUK New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Hello,

    I'm trying to delete my network adapters and start setting them up again, or reset the LAN networking and set it up from scratch. I was trying to implement Link teaming on my Realtek adapters, and it didn't work, and I ended up with adapter 1 and adapter 4. If I try and rename 4 to 2, it tells me 2 already exists, but 2 never shows up anywhere. So, I'd just like to set them up again.

    But, I can't delete them - I just get 'The connection you selected cannot be deleted". I've tried disabling the device in device manager, tried in safe mode, but no luck. It even appears to me that interface delete has been removed from netsh.

    Any ideas?

    thanks
    Dave
     
  2. DaveUK

    DaveUK New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Typically, a few minutes after posting this, it occurred to me I could try deleting them from the registry. I'll give that a go.
     
  3. DaveUK

    DaveUK New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Hmm.. bit too tricky for me doing it in the registry. Back to the original question.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    There is a few different things you can do that may get rid of any pre-existing information regarding the network connection names, but they all seem to me like using a machete when a scapel would be a better tool.
    Why don't you just rename the connections to something a bit more intuitive like wired and wireless, or perhaps, RealTekPrimary and RealTekSecondary?
    If you are looking to doing something a little more drastic you could try
    Device manager, uninstall the adapters and reboot....or
    Rebuilt the TCP/IP stack
    command prompt type netsh int ip reset C:\IpStackReset.txt ....or
    Reset Winsock
    command prompt type netsh winsock reset
    All three seem a little drastic if I understand correctly what you are attempting to accomplish.
     
  5. DaveUK

    DaveUK New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Hi, Thanks for the reply. It's not really the names that is bothering me. More the fact that I can't rename one of them to 2 since it tells me 2 already exists. This implies that everything is not clean. And since my real objective is to get teaming working, I do need a clean setup since the teaming software from realtek creates a new virtual adapter. I'm happy to do the ip reset - will that just give me a the default LAN1 and LAN2?

    thanks
    Dave
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I believe that just using device manager to uninstall both adapters and then rebooting and let the auto hardware install reinstall them will accomplish that for you.
     
  7. DaveUK

    DaveUK New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Thanks, uninstalling the two devices worked fine.

    I still can't get the teaming to work though. It's a longshot, but has anyone got realtek teaming working with Windows 7. I'm using a Shuttle X58 board.

    I heard realtek have stopped making/supporting their teaming software, so maybe that was because of Windows 7....

    thanks
    Dave
     

Share This Page

Loading...